Support » Plugin: GTM4WP » GTM4WP plugin 403 Forbidden

  • Resolved lutiluc

    (@lutiluc)


    Hi there!, when I activate the GTM4WP plugin, the website automatically returns the code: 403 Forbidden. The plugin pulls down the website.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Thomas Geiger

    (@duracelltomi)

    Hi,

    Do you have access to any web server log on your site?
    It is very hard to tell you the reason for that. But if you have any PHP error log or any web server log that could include a trance that would be beneficial.

    Thread Starter lutiluc

    (@lutiluc)

    Hi Thomas,

    Thanks for your answer! I am not a developer and I never accessed to the server, as soon as I find out how to get that information I will send it to you. Thank you very much!

    Hi,

    We also get 403 Forbidden code after we updated plugin to Version 1.16. There is no PHP errors but server log shows the following Apache error: (I have replaced sensitive data with *** characters.)

    [client ***.***.***.***] ModSecurity: Access denied with code 403 (phase 4). Match of “rx \\\\ssrc=\\\\x22https:\\\\/\\\\/www\\\\.googletagmanager\\\\.com\\\\/ns\\\\.html\\\\?id=GTM|\\\\ssrc=\\\\x22https:\\\\/\\\\/w\\\\.soundcloud\\\\.com\\\\/player\\\\/\\\\?url=” against “TX:0” required. [file “/etc/apache2/modsecurity.d/rules/comodo_free/19_Outgoing_FilterInFrame.conf”] [line “14”] [id “214540”] [rev “5”] [msg “COMODO WAF: Possibly malicious iframe tag in output||***.****.***|F|3”] [data “Matched Data: <iframe src=\\x22https://www.googletagmanager.com/ns.html?id=1\\x22 height=\\x220\\x22 width=\\x220\\x22 style=\\x22display:none found within TX:0: <iframe src=\\x22https://www.googletagmanager.com/ns.html?id=1\\x22 height=\\x220\\x22 width=\\x220\\x22 style=\\x22display:none”] [severity “ERROR”] [tag “CWAF”] [tag “FilterInFrame”] [hostname “***.***.***”] [uri “/index.php”] [unique_id “***”], referer: https://***.***.***/***/

    Plugin Author Thomas Geiger

    (@duracelltomi)

    Hi,

    Could you test if this fix also fixes this 403 issue?
    https://github.com/duracelltomi/gtm4wp/commit/7a0cfca7b32c79bb41b2abb96e97dfaf3ed3c639

    Thanks!

    Hi,

    I changed those lines and it indeed fixed 403 issue also.

    Thanks!

    Thread Starter lutiluc

    (@lutiluc)

    Hi Thomas,

    Thank you for your support.

    I have spoken with the hosting company and the error was due Because the ModSecurity was blocked. So we have added this rule to the white list, adding a rule (SecRuleRemoveById) to the .htaccess. With this it is already solved.

    Thanks

    Hi there!

    can you please share the exact rule you have added in .htaccess?

    Thank you in advance

    flatee

    (@flatee)

    @duracelltomi Thank you – the fix https://github.com/duracelltomi/gtm4wp/commit/7a0cfca7b32c79bb41b2abb96e97dfaf3ed3c639

    solves the issuew with the 403 error – please keep this in your next version.

    Thanks

    arm923i

    (@arm923i)

    @duracelltomi Tell me, how can I remove the extra “id” attribute with the data level, I only need the “item _id” attribute.
    In the js code itself, I do not observe this attribute, is it probably added at some other stage of sending?
    https://ibb.co/NWY7QKs
    Also, the price must be in numerical format. Added the parseFloat function, but it does not give a result, it just goes like text.
    https://ibb.co/1zN9GR2
    Thanks in advance

    Hi there,

    we had the same issue since we updated the plugin to version 1.16.
    With the help of this thread we fixed the 403 error by editing the core file.

    @duracelltomi Will this problem be solved by the next update so that we don’t have to edit the core file after each update? Before the update we never had any problems.

    Thanks in advance

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.