Support » Plugin: SEOPress, on-site SEO » Gtag code/script not added

  • Resolved izaakbeer

    (@izaakbeer)


    I am trying to activate Google Tag Manager to start tracking user actions on my website. I am using Oxygen Builder.

    I have added my Google Analytics Measurement code (G-XXXXXX), which works.

    Now, I want to add the two Google Tag Manager scripts using the “tracking tab”. I have added my script in the [head] and [body], but it does not appear to work. When checking the website source code, the Gtag script is never added.

    I am not logged in (using incognito). I do not use the cookiebanner feature (I use Complianz instead). It is also not caching (not enabled on site, browser cache cleared). So what could this be?

    The website is still set to no-index, which is why i really can not publicly share any URL. Could the no-index cause this? Neither the <head> or <body> scripts shows up.

    Thanks in advance!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter izaakbeer

    (@izaakbeer)

    Hmm… After resubmitting the changes (reclicking save), the script appears to show up (both in head and footer) – albeit without the <!– Google Tag Manager –> comments

    However, when trying the “Preview” in Google Tag Manager (to test the connection and if events fire), GTag does not connect to the site. Not sure why it doesn’t connect? (I am not logged in and all cookies have been accepted)

    • This reply was modified 4 months, 1 week ago by izaakbeer.
    Thread Starter izaakbeer

    (@izaakbeer)

    I’m such a noob…

    RESOLVED
    Brave browser shields block various end points of Google Tag Manager. Basically, you can’t track whoever uses Brave (including me). Its working just fine!

    — CLOSED

    Plugin Author Benjamin Denis

    (@rainbowgeek)

    Thank you for this update!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.