Support » Plugin: GS Logo Slider » gs slider not compatible with WP 5.0.1

  • Resolved CGC studio

    (@cgc-studio)


    Hi
    gsslider v.1.8 doesn’t work with latest WP 5.0 update, my website fall (white page on front and back-office) and I am compelled to disable your plugin to see my website come back to life again. : (
    here one the errors encountered:
    Fatal Error (E_ERROR): Call to undefined function register_block_type() occurred in wp-content/plugins/gs-logo-slider/gsl-files/includes/gs-logo-shortcode.php on line 121
    Please could you help me fixing this? mu site uses WordPress 5.0.1–fr_FR
    TIA
    CGC

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Golam Samdani

    (@samdani)

    Hi CGC,

    Thanks for the concern.
    What is the PHP version of you are using?

    Closures (anonymous functions) were added in PHP 5.3.0
    So please upgrade your minimum PHP version to 5.3.0 to function Logo Slider plugin.

    Please let me update.

    Thanks / Samdani

    wpblogwriter

    (@wpblogwriter)

    To CGC: in order to get your site working normally again, I would suggest that you reinstall the former version (1.7.2): just remove the gs-slider folder from the plugins folder and upload the plugin-folder which you can download here: https://downloads.wordpress.org/plugin/gs-logo-slider.1.7.2.zip.

    As a reply to Golam: you removed my comment as I was describing the same problem with WordPress 4.9.9.. anyways.. I am using PHP 7.x (the plugin is installed on multiple sites with multiple versions of PHP: 7.1. ad 7.2.). None of them is using PHP 5.x.

    Best regards,
    WBW

    CGC studio

    (@cgc-studio)

    Thank you Golam and WBW
    I’ll check this and let you know ! : )
    CGC

    CGC studio

    (@cgc-studio)

    Awaiting PHP information from my host, I tried to reinstal former version (1.7.2) (after deleting 1.8 version, of course) but WP doesn’t want to activate it !?
    I never saw such a behavior !
    Any idea of what could happen ?
    TIA
    CGC

    CGC studio

    (@cgc-studio)

    HI Golam
    The site hosting uses PHP Version 5.4.45
    CGC

    Plugin Author Golam Samdani

    (@samdani)

    Hi @wpblogwriter

    I didn’t delete any comments.
    In fact, I was not online.

    Waiting updates from both of you.
    I’m not getting any error & plugin working perfectly at my server.
    If need to modify, I’ll recheck tomorrow & release update.

    Thanks for your cooperation & updates.

    Thanks / Samdani

    CGC studio

    (@cgc-studio)

    The activation of former v. 1.7.2 produced the following error :
    Warning: require_once(/home/alliancej/www/wp-content/plugins/gs-logo-slider/gsl-files/includes/gs-logo-cpt.php): failed to open stream: No such file or directory in /home/alliancej/www/wp-content/plugins/gs-logo-slider/gs-logo.php on line 37
    Any idea of what could happen ?
    TIA
    CGC

    wpblogwriter

    (@wpblogwriter)

    Hi CGC,

    What was your previous version you were running?
    Maybe the 1.7.2 isn’t compatible neither.. You should donwload the version you already had. Just change the version in the link: https://downloads.wordpress.org/plugin/gs-logo-slider.1.x.x.zip

    WBW

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Side note:

    I didn’t delete any comments.

    And the author can’t delete comments here either. I archived them with this note.

    @wpblogwriter If you need support then per the forum guidelines please start your own topic.

    https://wordpress.org/support/guidelines/#post-in-the-best-place

    You can do so here.

    https://wordpress.org/support/plugin/gs-logo-slider/#new-post

    Which was also archived.

    But as you seem to be assisting this user with their problem (and keep it that way, this is not your topic) then the new comments stay.

    CGC studio

    (@cgc-studio)

    @ WBW,
    Thank you for wise advice. I found in older backup gs slider V. 1.6 and after downgrading this plugin version, it works fine now ! thanx a lot
    @ Golam,
    So the remaining question is: why latest v.1.8 doesn’t work on PHP Version 5.4.45 and WP 5.0.1 ?
    TIA
    CGC

    Plugin Author Golam Samdani

    (@samdani)

    Hi CGC,

    Thanks that it works finally but I’m not satisfied.
    As you are using WP 5.0.1, Gutenberg is by default available & register_block_type() function shouldn’t be undefined.

    Anyway, I wish to test more & can you write me at samdani1997 [at] gmail.com
    so that we can investigate more.

    Thanks for your cooperation.

    Samdani

    BeBizzy

    (@bebizzy)

    Same here. Site breaks when I update. Installed the previous plugins and still works.

    Running the site on Multi-PHP and a fairly new install so it should be running PHP 7

    Plugin Author Golam Samdani

    (@samdani)

    Thanks BeBizzy for the concern.
    Hope to update soon.

    Plugin Author Golam Samdani

    (@samdani)

    Hi All,
    CGC studio (@cgc-studio)
    wpblogwriter (@wpblogwriter)
    BeBizzy (@bebizzy)

    Released version 1.8.1 by fixing Gutenberg Block for the old Gutenberg version compatibility.

    Please check by upgrading to latest version.

    Let me know if you face any issue.

    Thanks for your cooperation.

    Regards/ Samdani

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘gs slider not compatible with WP 5.0.1’ is closed to new replies.