Support » Plugin: Groups » Groups Read Access to pages not working

  • Resolved katjmars

    (@kmarschner)


    We recently added the Groups Plugin to our site, created the groups and applied the “Read” option to a couple of pages and one specific group. After adding a select set of test users to the group and adding the group to the “Read”, the page is not visible to the members of that group.

    We’ve used the plugin before on other sites with no issues but now it appears to not be working

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter katjmars

    (@kmarschner)

    If we remove the group(s) in the “Read” the pages become visible to anyone. We’ve tried with multiple groups, multiple users and different combinations

    Hi there,

    Good morning. I trust you are well and safe!

    Based on the information you’ve shared, your pages ought to render for the users you’ve assigned to the group.

    Please can you try adding a read capability to the group. You can do this by navigating to Groups > Groups. Then proceed by editing the group in question and in the Capabilities option select the read capability and click on Save.

    Then please ensure the user is indeed assigned to the group. Just in case, please can you also update your Groups plugin to the latest version if you haven’t already. The latest version should be v2.16.2.

    If that does not work then it might help a lot if you enabled WordPress debugging as there might just be a conflict.

    Best,
    Eugen.

    Thread Starter katjmars

    (@kmarschner)

    Thanks for the response @eugenbleck.

    Agreed we feel like things should be working as expected but we haven’t had much luck. We added a new test page and assigned a new group to the Read option on the page.

    I did confirm that the capabilities included only ‘read’ and also added in the ‘read’, ‘read_private_pages, and ‘read_private_posts’.

    Confirmed that the user was added to the Group – and in fact that the user was the only member of the Group. Navigated back to the page and it was unable to be displayed with our standard “Not Found. Sorry, but the page you were trying to view does not exist.” message.”

    If I remove the Group from the Read menu which Restricts the visibility of this Page to members of the chosen groups, then the page becomes visible again.

    I did confirm that we have Groups v2.16.2 and unfortunately turning on Debugging doesn’t provide much insight. There are no references to any conflicts, notices or warnings that we’ve not seen before.

    Plugin Author Kento

    (@proaktion)

    Hey there,

    This could be an issue with caching or a conflict with other plugins.

    Important: I would advise not to assign any particular capabilities to the group(s) involved, these are not needed if you restrict access to pages based on groups as shown on the Access Control documentation pages. Actually make sure you do not inadvertently open up permissions that normal users should not have by assigned capabilities to those groups.

    Here’s what I would recommend to do so you understand how this works normally:

    1. Disable all non-essential plugins, including any caching plugins on your staging site.
    2. Create a new group “Test”
    3. Create a new page and call it “Test Page”
    4. Set the “Test” group restricting access to the “Test Page”
    5. Create a new user called “Test User” and assign that user to the “Test” group
    6. Test access to the page: use a different browser and try to access the “Test Page” => should yield “not found”
    7. Now log in as the “Test User” and try to access the “Test Page” => should show the restricted page

    That’s how you can make sure you understand how it’s supposed to work and test it. Now go ahead and enable other plugins individually while testing, see if there’s a difference between the expected results and what you get when those other plugins are enabled. If anything changes, you might be on to a conflict. Also check you caching plugin to see if any of its settings might be related to how cached content is served to plain visitors vs users who are logged in.

    Keeping this open to see what you find out …

    Thread Starter katjmars

    (@kmarschner)

    @proaktion – I was able to narrow down what appears to be the problem using some of your suggestions in creating a native user from the WordPress side.

    It appears that when users log into our website using our SSO solution, regardless of the Groups they’re assigned to, the Groups page restriction is not being applied as expected.

    When the same user logs in using the ‘/wp-login.php?wpe-login=true’ link the Groups page restrictions are applied.

    Plugin Author Kento

    (@proaktion)

    @kmarschner Thanks for the info! Could you please clarify? :

    – Which SSO plugin are you using?
    – Regarding this “… regardless of the Groups they’re assigned to, the Groups page restriction is not being applied as expected” – I guess what you mean is that when a group member logs in using the SSO, he still can’t access the restricted page, right?

    Plugin Author Kento

    (@proaktion)

    Assuming solved, do follow up however if this is still an issue you need help with.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.