Support » Plugin: Plugin Organizer » Grouping Problem; creates duplicate entries

  • Resolved GeneralReason

    (@generalreason)


    Recently started experiencing problems with Grouping. When I create a group and then try to add plugins to it I end up creating another group with a duplicate double name. For example If I create a group called “management plugins” and then later select a group and go to -Add to Group- selecting “management plugins” as a group a new group gets added called “mangement pluginsmanagement plugins”. Further more some plugins dont even show up when you click the group even though Plugin Organizer says they are already assigned groups. I’ve also tried using the -save to group- option but the problem persists. The plugin used to work fine. I dont know why its acting up like this. Can you please help?

    http://wordpress.org/extend/plugins/plugin-organizer/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    I’m not able to recreate the issue on any of my sites. I also haven’t heard of anyone else having this problem. Try deactivating and reactivating the plugin to see if something didnt get set right on activation.

    Thanks for the reply..
    I have been up all night troubleshooting.
    I have concluded that the issue only occurs when I try to group certain plugins. “Ozh’ Admin Drop Down Menu” & “Ozh’ Better Plugin Page” were the two particular ones!!! 😐 I guess the resolution would be dont use a plugin that you cant Group! Ozh’ Better Plugin Page alone was conflicting with Plugin Organizer. Perhaps you can replicate my problem if installing one of those plugins & further determine the reason for the conflict.

    Until then I will stay away from them. 🙂

    I might run into the same issue grouping other plugins. I have over 300 plugins 😐

    Nice Plugin

    Thanks Jeff

    Plugin Author Jeff Sterup

    (@foomagoo)

    I see what you are saying. I don’t get a duplicate group but the plugin doesn’t show up in the group when I add it. It is because WP is escaping the ‘ character when it is inserted into the database but not when it is comparing. I’m working on a fix and should be releasing it later today.

    -in response to you not seeing the duplicate aspect: Did you install both plugins? Try adding either of them to a group. It should be an easy replication. If you cant then its gotta be a conflict with some other plugin I have.

    Glad u see what i’m talking about. 🙂
    Keep me posted.

    appreciated..

    Update:
    done some further troubleshooting..
    I believe the duplicate issue is replicated when you try add to an existing group from the Recently Active Listing. Adding it from any other listing including a search listing adds it just fine.

    Suggestions for Future Enhancements:
    -a way to list plugins not grouped
    -a way to edit group names

    Thanks

    Update:
    A plugin which works great in combination with yours is ‘himi’s Plugin Organizer’. This plugin also doesn’t show up in the assigned group after you assign it, although your plugin says its in the group.

    Plugin Author Jeff Sterup

    (@foomagoo)

    I have released 2.5.8 that should fix these issues. Took me a little troubleshooting to figure out the recently active plugins problem. It was because the bulk actions menu was being duplicated. Update to the new version and let me know if your problems are fixed.

    Plugin Author Jeff Sterup

    (@foomagoo)

    Sorry I messed up the 2.5.8 release. I missed one of the files. I have released 2.5.9 that should have everything in it.

    Tested & Working!

    good work!

    Thanks alot Jeff!

    greatly appreciated!

    resolved!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Grouping Problem; creates duplicate entries’ is closed to new replies.