Support » Fixing WordPress » Group Permissions set to zero

  • Resolved DonnEm


    I have been haing a problem with media files on my new installation of WordPress. Two things are going wrong.

    First, the multi-file uploader does not work at all for my Windows 7 64-bit system to upload jpg files. I can upload single files using the browser upload.

    Second, when I try to add media to a page from the image library, jpg thumbnails are blank with Xs in them. When I click on one of the blank thumbnails, I can place it on the page, but I work “blindly’ in that no image shows up on the page until I publish. Until then I only see a blank box on the page with incorrect dimensions.

    I checked file permissions using Filezilla, and wp-admin, wp-cvontent, and wp-includes primarily have folder permissions of 705 and file permissions of 604. My webhoster insists that the user group settings of zero are fine for WordPress. Anyone have any experience with this? I am on a shared system, and want to keep permissions as low as possible for as many files as possible.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Have you tried temporarily upping them on a specific couple of files or one directory and seeing if it makes a difference?

    I have tried to up it on a couple of files (and the directory) in Uploads to no avail. I’m not really sure which files to experiment with.

    Ok, time for WordPress troubleshooting 101. Have you tried with all plugins disabled and using the default theme?

    Yes I’ve tried all that. In fact, it wasn’t working correctly right after the install.

    But I just discovered something. I believe the reason the jpg thumbnails are blank and the blank box appears on a page (instead of the image itself) may be due to the fact that I’m in “dns-preview” mode.

    I compared the page html text before and after “publish” and discovered a difference between the two. After publish it lists the normal url; prior to publish it lists the dns-preview url. it cannot find the file because its looking in the wrong place.

    Perhaps the multi-file uploader is running into something similar. I’m not yet ready to go public yet, so I’ll continue to use dns for a few days to get the webpage looking somewhat reasonable. After I go public, I’ll check back again.

    Thanks Andrew for trying to help a beginner. (I still don’t know why filefilla shows GROUP permissions at 0 for most of the wordpress files and directories though.)

    Sorry, what’s DNS preview mode?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Group Permissions set to zero’ is closed to new replies.