Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Grid Form Feature Image Not Visible

  • Resolved redoact

    (@redoact)


    Hi Team,

    My grid form feature image is not visible. Everything is in the insert shortcode are right.

    Feature Image is Enabled and set as show.

    Please help.

    Thanks
    Redoact

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Ben Meredith

    (@benmeredithgmailcom)

    Hi @redoact,

    That’s a great looking site! Happy to help you figure out what’s up with the form grid images.

    In the markup of the page, it is not there at all, so that rules out some CSS hiding it. Can you pass along the exact shortcode you are using?

    The parameter you need to set is show_featerured_image="true" in the shortcode. Our documentation is referencing the options in the shortcode builder, which is confusing. I am going to make sure those are clarified a bit.

    Thanks for bringing this to our attention!

    Hi Ben,

    Thanks for your kind reply.

    Shortcode

    [give_form_grid show_featured_image=”true” display_style=”redirect” forms_per_page=”12″]

    Thanks
    Redoact

    Are you using GiveWP v2.7.3 with the [give_form_grid] shortcode? What is the exact shortcode you’re using? Is it like the following Give Form Grid shortcode example?

    [give_form_grid columns="3" show_goal="true" show_excerpt="true" show_featured_image="true" display_style="modal_reveal" forms_per_page="12"]

    You could also use the Form Grid block to show the featured image which is recommended if you are using the WordPress block editor: https://givewp.com/documentation/core/blocks/form-grid-block/.

    I hadn’t seen the reply from @benmeredithgmailcom, but when you, @redoact, use display_style="modal_reveal" instead of display_style=”redirect”, the featured image shows up.

    Hi Michael,

    No, its not working when its in modal_reveal also.

    Please help me.

    Thanks
    Redoact

    When I test using GiveWP v2.7.3, the featured image shows using the following:

    [give_form_grid show_featured_image="true" display_style="modal_reveal" forms_per_page="12"]

    Make sure you’re using " instead of . Can you copy the above shortcode and does the featured image show?

    Hi Michael,

    I have updated with your shortcode, but not working.

    please check here

    https://redoact.com/donate/

    Thanks Bro!

    If you’re not using GiveWP v2.7.3, can you update, and does the featured image show with the above shortcode?

    Another option if you’re using the WordPress block editor, is to use the Form Grid block to show the featured image.

    Hi Michael,

    I am using the latest version of GiveWP v2.7.3.

    No i am not used to wordpress block editor.

    Please help me

    Thanks

    Hey @redoact,

    Are you using the following shortcode now?

    [give_form_grid show_featured_image="true" display_style="modal_reveal" forms_per_page="12"]

    When I use use that shortcode with GiveWP v2.7.3, the featured image shows.

    Hi Michael,

    [give_form_grid show_featured_image=”true” display_style=”modal_reveal” forms_per_page=”12″]


    Yes its not working. Please check

    Thanks

    @redoact It may be that there is some incompatibility between a plugin or your theme and GiveWP. I recommend you follow this troubleshooting tutorial using the Health Check plugin. It allows you to isolate plugins and change themes for an administrator, while the frontend still runs the live version of the website. You can see the documentation here: How to Troubleshoot WordPress Websites with Health Check. You can also check out this other tutorial: How to Troubleshoot Your Website like a WordPress Support Engineer.

    Let me know what you find when you try those tutorials and it will be easier to identify the root cause of the issue.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.