WordPress.org

Forums

greymatter archives 2 wp (9 posts)

  1. witchy
    Member
    Posted 12 years ago #

    Hello :)
    I know that you answered this for someone trying to import blogger posts. The post I'm trying to import is greymatter.
    I filled out the info, in the gm-2-b2 php, but than I get a problem. It says...
    The importer is running...
    importing users...
    Oops, can't fine any database name here !
    so. Am I forgetting to do something? Or do I have the wrong info? Because greymatter didn't have a database.
    Any suggestions? of Info?
    Thanks!

  2. Julian
    Member
    Posted 12 years ago #

    I ran gm-2-wp.php a <i>long</i> time ago when it was gm-2-b2.php so I have a lack of experience here, but here goes my guess: Check your b2config.php to make sure that the database name is correct for the database that you are going to be placing the posts into. The error message suggests (to me) that the script can't find the WP database as opposed to the Greymatter database. Good luck!

  3. witchy
    Member
    Posted 12 years ago #

    I'll check, but Greymatter didn't have a database. (duuuuh... This may be the problem? *G*)
    Honest, I did think that, but I was hoping that, perhaps, since Greymatter is CGI and has an "archive folder", that was fine. But if Greymatter was suppose to have a database for it, well, it never did, so I guess she wouldn't be able to import the archived post after all?

  4. Guido
    Member
    Posted 12 years ago #

    adding Julian's reply,
    Recall from the file gm-2-b2.php itself, that error message occur during connection failure to mysql database .
    So, there must be something improper on your database config at b2config.php
    Anyway, I couldn't find file gm-2-b2.php in wp packages. Is it somewhere else?

  5. shelleycat
    Member
    Posted 11 years ago #

    I am currently having exactly the same problem as the first poster here. My databases are set up correctly and are correct in b2config.
    Since gm-2-b2 seems to be no longer packaged with the wordpress download I grabbed the latest one I could find in CVS. I did have to make one change, near the top it asks for wp-config.php which doesn't exist in the rest of the 0.7.1.1 release I've installed, so I changed it to say b2config.php (which is the file I have). I don't know if this will make any difference.
    I also tried the old gm-2-b2.php files from my previous b2 install, but this time got the error messages:
    Warning: main(/b2-include/b2functions.php) [function.main]: failed to create stream: No such file or directory in /home/shelley/public_html/delwyn/blah/gm-2-b2.php on line 8
    Fatal error: main() [function.main]: Failed opening required '/b2-include/b2functions.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/shelley/public_html/delwyn/blah/gm-2-b2.php on line 8
    I've already previously tried installing b2 0.6.1, importing the gm files (successfully) then upgrading to wordpress 0.7.1.1, but the files became garbled somehow in the b2-2-wp conversion so I deleted everything and started again.
    I'd love to convert that old GM blog and start using the new WordPress goodness :D

  6. JoshS
    Member
    Posted 11 years ago #

    I'd love to do this, as well, but there seems to be little, if any support around here... Even a simple "it can't be done" would be better than nothing!

  7. Matt Mullenweg
    Troublemaker
    Posted 11 years ago #

    The GM converter is relatively old, and none of the current developers had any hand in its development. If someone is willing to donate their files for testing I'd give it a look.

  8. gfmorris
    Member
    Posted 11 years ago #

    Allusion: I'll be more than happy to give you 990 GM files. :D

  9. gfmorris
    Member
    Posted 11 years ago #

    Offer still stands. :D

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.