• Resolved exius

    (@exius)


    Hi,

    I’m reposting my question since I have not received any replies in almost 2 whole weeks. Maybe it was missed somehow…

    GiveWP seems very promising, however, after hours of troubleshooting I still cannot get see the form. Only upon changing the theme to legacy does it show up.

    I noticed during the setup wizard the follow error alert ajaxURL has NOT been defined but after clicking ok and finishing the steps it seemed to have been setup.

    After the form is created, I clicked preview (or view) and it just shows the spinning green circle.

    I have removed all password protection to my site, disabled all caching, change my theme to twenty twenty, and disabled all plugins except GiveWP and it still does not work!

    Please let me know what’s missing here.

    Exius

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Matt Cromwell

    (@webdevmattcrom)

    HI there,

    Can you provide a link to your form so we can see the problem live? That will give us the MOST insight in how to help you troublehsoot this quickly.

    Also, we have a troubleshooting guide related to AJAX issues in our docs, see here:
    https://givewp.com/documentation/core/frequent-troubleshooting-issues/admin-ajax-blocked/

    I’m having identical problems, save for the Ajax issue. I haven’t seen anything in my screens that says there’s anything up with Ajax. But when someone clicks on a link to be taken to a donation page the green circle just spins and spins. I’ve left it for 20 mins once and nothing happened.

    Here’s a form URL to show you:
    https://www.pedonation.xyz/index.php/donations/example-donation-form/
    (please don’t ask about the domain name! It’s a long story and isn’t permanent)

    Plugin Support Rick Alday

    (@mrdaro)

    @funkydan the link leads to a 404 page. Can you double-check?

    Thanks!

    I see it does. Go Figure. Here, I finally setup my own domain for the testing, and I moved it there. Here’s a URL that I just tested and it works:

    I will try to figure out what happened to the other link later.
    https://www.newideatest.site/index.php/donations/donation-form/

    I just loaded this in my browser and it came up correctly (or incorrectly, as in I saw what I expected, not what I wanted)

    BTW, just in case it was browser specific, I tried it in Firefox and in Chrome. Same result in either browser.

    Plugin Support Rick Alday

    (@mrdaro)

    @funkydan

    Thanks for the update. The new GiveWP form template loads the form via an iframe. The iframe content should also be available via the browser but when I tried to access it directly I get a “not found” message from the server: https://www.newideatest.site/give/donation-form?giveDonationFormInIframe=1

    Try changing your Permalink structure to one of the pretty permalinks such as. “Day and name” or “Post name”.

    I can try, but last time I used a pretty permalink NOTHING could be found. It was 404 for every non-admin page I tried to access.

    Okay, I set to date and name permalink structure. And when I reload that URL, I get a 404 again! I even edited the page in the donation plugin and re-saved it, still 404!

    This is a problem I explained over a month ago and never got any resolution for. The “ugly” permalink structure is the only one that actually works!

    So, after going through and completely deleting the WordPress config and re-creating a donation page using the old single-page style form, I got the form to come up. But when I tried to make a test donation I got another 404. The URL it sent me to was:
    https://www.newideatest.site/donations/10/?payment-mode=manual

    I’m completely lost! Help???

    Plugin Support Rick Alday

    (@mrdaro)

    Hi @funkydan,

    In your WordPress dashboard, navigate to Settings -> Permalinks, and select one of the preset permalink structures except for Default. You can use “Day and name” or “Post name”.

    Save the settings and let us know if it helps.

    What you want to avoid here is having the “index.php” part in your URLs.

    funkydan

    (@funkydan)

    I tried this with much trepidation, and sure enough, using any permalink structure that hides the index.php results in 404 errors EVERYWHERE. It’s an issue I’ve tried unsuccessfully to get dealt with before. The main page works fine, but if I try to click in my “Hello World” post I get a 404 error. In fact, clicking on ANY link on the front page gives a 404 except those that give an absolute filename (i.e. login.php) or those that lead to external sites (i.e. wordpress.org)

    I guess I can re-create an issue of that, but last time no one had any good ideas on fixing it. Everyone said “That should work” but it didn’t.

    Plugin Support Matheus Martins

    (@matheusfd)

    Hi @funkydan,

    I do apologize for my slow turnaround on this one.

    Are you still facing this issue? If you are, please update to the newest version of the plugin, 2.9.1, and let me know if the issue persists.

    Looking forward to helping you get to the bottom of this!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Green spinning wheel!’ is closed to new replies.