WordPress.org

Support

Support » Plugins and Hacks » [Resolved] green bar in Safari on rollover/hover

[Resolved] green bar in Safari on rollover/hover

Viewing 4 replies - 1 through 4 (of 4 total)
  • sammymaudlin
    Participant

    @sammymaudlin

    Does it in Firefox as well I just discovered. Both of these are on my Mac.

    sammymaudlin
    Participant

    @sammymaudlin

    It looks like that it is a green box with a darker green border that displays alt-text for the icon images. If that’s the case, how do I turn that off?

    sammymaudlin
    Participant

    @sammymaudlin

    Figured it out. For anyone using the custom-link option there is a line in the custom-link.php file (in the Plugin editor) that reads:

    echo ‘ class=”fsml_customlink”><img src=”‘ . $imgurl . ‘” class=”fsml_customicon” alt=”More” title=”‘ . $title . ‘” />’;

    I deleted “More” and that got rid of all of the alt text. Probably works with the other php versions too.

    Plugin Author Nick Halsey
    Participant

    @celloexpressions

    That’s probably coming from the title, not the alt text, although I can’t replicate the behavior you’re seeing. The browsers probably aren’t handling blank title attributes well, or perhaps they just have a single space which is showing the title popup on mouseover.

    I would recommend just putting in a title on the custom link that describes what the link does, since that’s good for SEO anyway. I also fixed the alt tag to replicate the title in the version I’m working on that merges the temporary plugin into the main one. Of course, removing the title and alt text should prevent what you’re seeing from coming up too, although they’re there for a reason.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] green bar in Safari on rollover/hover’ is closed to new replies.