Support » Plugins » Great Suggestions

  • Thanks – Great.

    It would be nice if we could customize the location of the uploads folder – such as wp-content\uploads\ or wp-content\uploads\hotlinkcached\
    so all my uploads are in one place.

    Being 777 (owner/group/world), does that mean anyone can write there? Could hot linked image cacher be set to work with 775 permissions?

    For some images, I want to cache/backup the remote images, in case they are removed/changed, but until that problem arises, I still want to retrieve the image from their site.
    While I would like the extra traffic I could get from image search results, I don’t want the websites from whom I copy excerpts or images to resent me, so I should let those image search results point to their site.

    (I acknowledge that I do want the images sourced from my site because that will surely speed up page loading times, by ?many milliseconds?.)

    So, the changing of the img src link should be optional, image by image, or at least website by website, or at least post by post (so if I select ‘all’, I get presented with a list of images to be cached, and I can de-select ‘change image source link’.)

    The folder upload was not automatically created for me. I used the one-click install plugin to install it (and the regular plugins.php page to activate it). Could the folder upload just be included in the package? (Ah, but I guess you can only set permissions to 777 for new folders, so that wouldn’t work.)

    I had been unable to get the plugin “cache images” to work, it always said my directory was not writable, when it was indeed 777 (writable). With your new plugin, when I set the directory to 777, the plugin works.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Thanks for the feedback, I will put some of these suggestions in the next version.

    Actually set the folder to 644 would probably work if the server is configured correctly. For example I use dreamhost for hosting and the plugin does not need the folder to be 777, it works at the default setting (644). My suggestion would be only set it to 777 if the plugin tell you the folder is not writable.

    I just moved to a VPS and I have the same problem. If I try to set it up with 644 it knocked my plugins and theme. If I keep it 777 it works. If I put it 755 WP-Cache says it can’t work because the directory is not writable.

    If I need my tech support to make a change to the server what do I need to tell them?

    I would say just keep it at 777 if it works for you. Since you want to show the content of the cache folder to the world anyway. There is no security risk associated with it. No one will be able to write to that folder regardless of the folder setting, the only exception are those people who share the same server with you. If you are on VPS, there is nothing to worry about since you are the only one on the virtual server.

    Well I ended up getting it to work on 644 but I had to change the user to Apache. I could only do that at the root access level.

    can I download themes to use / adapt on an apple running leopard?

    Great plugin, thanks.
    I have a suggestion though, it would be nice if it got a feature to autocache via a cronjob or something.



    Sry for the double post.

    But I noticed that the plugin also lists images that are already cached

    I.e. the local images are also listed for caching on the We found some goodies. Check the domains that you want to grab images from page

    This is a great plugin, but I would really love it if it could cache hyperlinked images. When I import Typepad posts for example, the images have a larger hyperlinked image wrapped around a smaller image (i.e. < a href=”(larger image)”>< img src=”(smaller image)” >< /a >), which is what the cache-images and hot-linked-image-cacher plugins are able to cache successfully. It’s the larger hyperlinked image that doesn’t get cached and that poses a problem when the Typepad account gets deleted and those images are lost.

    I apologize if this has already been addressed already, but I have yet to find any solutions to the problem in my search.

    Hi, I am also using Dreamhost, but it seems that they have changed server permissions?

    Anyhows – I’ve looked a bit around and found suggestions to use cURL instead (see Dreamhost Forum)

    Is a cURL version of this plugin an option?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Great Suggestions’ is closed to new replies.