Support » Plugin: Creative Commons Configurator » Great plugins, any support for the AMP ?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author George Notaras

    (@gnotaras)

    Hi @houssenmoshine

    Thank you very much for the review! It is much appreciated!

    About the AMP pages, as far as I can tell the plugin adds the licensing information at the end of the article and also the Separate Media License feature seems to add licensing metadata for each media file that is included in the post.

    Am I missing something? I’d be grateful if you provided a little more information in the forums about the interoperability with the WP-AMP plugin. Or if you use another plugin, I’d be very interested in adding support for it.

    Thanks again for the review!

    Kind Regards
    George

    It’s related to the style and a attribut of p. I enabled the blocl, header and rss licencing. Here the errors :

    First Error :

    he mandatory attribute 'amp-custom' is missing in tag 'style amp-custom'.

    In the code :

    <!-- BEGIN License added by Creative-Commons-Configurator plugin for WordPress -->
    <link rel="license" type="text/html" href="https://creativecommons.org/licenses/by/4.0/" />
    <style type="text/css">

    Second Error :

    The attribute 'prefix' may not appear in tag 'p'.

    Error in the code :
    <p prefix="dct: http://purl.org/dc/terms/ cc: http://creativecommons.org/ns#" class="cc-block">Cette Ĺ“uvre est sous <a rel="license" target="_blank" href="https://creativecommons.org/licenses/by/4.0/">Licence Creative Commons Internationale Attribution 4.0</a>.</p>

    Plugin Author George Notaras

    (@gnotaras)

    Hi @houssenmoshine,

    First of all, I’m sorry for the late reply, but I received no email notification about your latest post.

    I’ll take a closer look at these issues and reply back. Your feedback is much appreciated!

    Since this review system is not the right place for support and troubleshooting, can we please move this discussion to the Github issue tracker?

    Some questions:

    – What is the document type of your HTML pages? The HTML output of CC-Configurator is now compatible with HTML 5. Previous versions of the plugin generated HTML code exactly as generated by the online tools of the Creative Commons web site. But, that code did not validate as HTML 5. So, since HTML 5 has become standard practice these days, I decided to move forward and change it.
    – What validator service do you use?

    I’ll need to do some research about the ‘amp-custom’ class.

    Kind Regards,
    George

    Plugin Author George Notaras

    (@gnotaras)

    About the first error, you are right. It needs to be fixed. This is about the inline style. I haven’t made any changes to it, because I plan to remove it and use an external style enqueuing it according to the standard WP best practices. And in that case, this will be taken care of by the AMP plugin.

    About the second error, it could be fixed by customizing the outer HTML code. But, I just discovered a small issue with it, so this customization will be possible from 1.8.20.

    George

    Plugin Author George Notaras

    (@gnotaras)

    Hi @houssenmoshine

    The customization of the outer HTML will be possible in 1.8.20.

    I haven’t made any changes to it, because I plan to remove it and use an external style […]

    About the stylesheet, for technical reasons, the inline style had to stay as is (didn’t manage to find a way to use the color related variables with external stylesheets). But the issue with the AMP page has been fixed.

    I haven’t heard back from you here or on github, so I won’t post more details about it. Please check the changelog of 1.8.20 for more info. I’ll try to make a release soon.

    Kind Regards,
    George

    Hi, thanks for the fix. For now, i have disabled the plugin. I will try with the new release.

    Plugin Author George Notaras

    (@gnotaras)

    OK, please report any issues you notice. Thanks for your feedback!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Great plugins, any support for the AMP ?’ is closed to new replies.