Support » Plugin: YouTube Channel » Great plugin with Requirement Issues

  • I would rate this plug with 5 stars except that it nags you on every screen in the dashboard that it requires PHP 5.3.29.

    RHEL 6 variant Linux distros at time of writing this are at PHP 5.3.3. If you look at the number of WordPress installations on RedHat, Fedora and CentOS, this impacts a significant number of installs, particularly in shared hosting environments.

    Are there really features of this plugin which require 5.3.29 or could the PHP version check be modified to simply check for 5.3?

    At very least, the warning message should be something that can be dismissed and limited to the limited so that it only appears on its own Setup screen and possibly the plugin screen.

    As a general design principle, I would argue that a plugin should not have stricter system requirements than the most recent version of the core engine that it lives inside (in this case WordPress 4.1.1).

    Nice plugin, easy to set up, looks great on my site but I can’t recommend it to clients.

Viewing 1 replies (of 1 total)
  • You are right, partially.

    I will add option to dismiss notification. At the moment it must be displayed in dashboard because requires Redux framework. If you don’t have Redux, you’ll never see PHP version “requirement”.

    Also, requirement does not means “will not work with older PHP” but some aspects can fail. I had couple users complains how something does not work with feed, and after all I found its PHP 5.2. As I don’t have access to such old PHP (and won’t bother to get it because couple users of free plugin), I stick 5.3 requirement.

    And, you are right, I’ll change notification for 5.3 instead 5.3.29.


Viewing 1 replies (of 1 total)
  • The topic ‘Great plugin with Requirement Issues’ is closed to new replies.