WordPress.org

Forums

WP Ajaxify Comments
[resolved] Great Plugin, just doesnt appear to work on the front page. (14 posts)

  1. marketraisen
    Member
    Posted 10 months ago #

    Works perfect, just not on my index page with comments added to it.

    Any idea what I can add to the settings to get me going?

    https://wordpress.org/plugins/wp-ajaxify-comments/

  2. marketraisen
    Member
    Posted 10 months ago #

    Looks like my problem is having multiple forms on one page, at least I know what to look for now.

  3. janjonas
    Member
    Plugin Author

    Posted 10 months ago #

    The plugin supports multiple comments per page. You need to set the setting "Post container selector" in the "Expert settings" section. Please send me a link to your WordPress site if you need further assistance.

    Hope this helps...

  4. marketraisen
    Member
    Posted 10 months ago #

    It's ok, I got there in the end.

    Thanks for looking in.

  5. janjonas
    Member
    Plugin Author

    Posted 10 months ago #

    Thanks for the feedback.

  6. marketraisen
    Member
    Posted 10 months ago #

    Yeah, I didnt get it to work on my front page, just on single posts, so my solution was to not use the plugin at all (!).

    Would you mind taking a look at my site to see if I'm missing something obvious? I've activated the plugin and not touched any of the settings, youll see its working on single post pages but not on the front page, I don't have a clue what to put into the fields on the settings page.

    I've tried div[id^="article-"] and div[id^="post"]

    mugbet.com

  7. janjonas
    Member
    Plugin Author

    Posted 10 months ago #

    Please try the following settings:

    Post container selector: div[id^='post-']
    Comment pages URL regex: .*

    Hope this helps...

  8. marketraisen
    Member
    Posted 10 months ago #

    Plugin Settings: WP-Ajaxify-Comments 0.24.1

    Settings not saved! Please correct the red marked input fields.

    ______

    Theres no combination of [space].* that the plugin will accept for the Comment pages URL regex, it doesnt want it.

  9. marketraisen
    Member
    Posted 10 months ago #

    /.*/

    that works to an extent, its progress at least, after using it it still says 'reloading page' but I'll try and go from there.

  10. marketraisen
    Member
    Posted 10 months ago #

    Ok, so on the front page it says 'reloading page' but on a single post page it does a regular refresh. If I had to choose I'd rather have it working on the front page over a single page so I shall persevere.

    Would it help if I changed the automatic redirection after a comment is posted or shouldnt it matter?

  11. marketraisen
    Member
    Posted 10 months ago #

    OK. Got it to work by adding just /.*/ to th comment url regex and leaving the post container selector empty.

    Thank you for the help and the awesome plugin!

  12. marketraisen
    Member
    Posted 10 months ago #

    Sorry, no more spamming form me.

    I had to add a unique id to the comments form in comments php-

    <div id="comments<?php the_ID(); ?>" class="comments-area">

    Under Comments container selector I had to put-

    div[id^='comments']

    Under comment pages URL regex-

    /.*/

    Now it works, awesome, thank you. That mugbet.com site is just a test site for me so you wont see it working, but it does.

    Thanks again.

  13. janjonas
    Member
    Plugin Author

    Posted 10 months ago #

    Glad to hear that you find a solution :).

    Please think about write a short review or make a small donation to support the plugin. Thanks in advance...

  14. marketraisen
    Member
    Posted 10 months ago #

    Sent five bucks and left a 5 star review.

Reply

You must log in to post.

About this Plugin

  • WP Ajaxify Comments
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags