• I like this plugin, but unfortunately, I am getting a lot of spam still (including messages in Russian), and there is no way to mark messages as such, or to filter them out. The only options are to either view or delete the messages. I have had both the recaptcha and the anti-spam honeypot options enabled since I first got the plugin over a year ago, but they don’t seem to be working to filter out the spam messages. Are they any options to fix this for non-premium users?

    • This topic was modified 1 year, 8 months ago by cher443.
Viewing 1 replies (of 1 total)
  • Plugin Support sanjuacharya77


    Hi @cher443,

    Thanks for the feedback and we are really sorry to hear that you’ve received spam.
    But since there is no issue on our test environment with receiving an spam after using the Google reCAPTCHA and honeypot feature of the Everest Forms.

    Could you please provide me the URL of the form if possible? Also please make sure that you have enabled honeypot and Google reCAPTCHA in your form. Incase if some setting are missed, here is the supporting documentation for its configuration:Google reCAPTCHA and Honeypot

    In addition to this, you can consider the third party plugin as well in order to protect the spam: Spam Protection, https://wordpress.org/plugins/cleantalk-spam-protect/. I hope this will help.

    If still there is an issue, then feel free to contact us from here and we will look into your issue more deeply.

    Thanks and Regards!

Viewing 1 replies (of 1 total)
  • The topic ‘Great plugin, but spam controls aren’t working’ is closed to new replies.