Support » Plugin: LT Unleashed » Great plugin but doesn’t work on HTTPS unless you use this hack

  • Great plugin and works well although I still can’t get the single book feature working.

    An issue is that LibraryThing don’t supply the URLs from Amazon using HTTPS so if you have an SSL on your WP site the covers will be broken. Unless you do this:

    Install ‘Real-Time Find and Replace’ and configure as follows:

    Find ‘ecx.images-amazon.com’ and replace with ‘images-na.ssl-images-amazon.com’

    All covers will now be served via HTTPS.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Claude Vedovini

    (@cvedovini)

    covers are broken or you’ve got a “mixed content” warning from your browser because your site is using SSL but the covers don’t?

    Thread Starter joomla-is-better

    (@joomla-is-better)

    They were broken until I fixed it with this plugin and change the URLs in real time.

    Plugin Author Claude Vedovini

    (@cvedovini)

    so you mean the cover urls that the LibraryThing API is returning are not valid? they link to 404 or server errors?

    Thread Starter joomla-is-better

    (@joomla-is-better)

    No I mean that they won’t work on a site using HTTPS as they show broken because the default Amazon URI isn’t over HTTPS.

    Plugin Author Claude Vedovini

    (@cvedovini)

    I guess it’s a setting on your browser, mine only gives me a warning because of the mixed content in such cases. Good find tho, I probably can include that directly in the plugin.

    Plugin Author Claude Vedovini

    (@cvedovini)

    I just posted an update to the plugin that should solve that problem

    Thread Starter joomla-is-better

    (@joomla-is-better)

    And it does. I’ve updated and removed the replacer plugin and the images are showing OK.

    Thanks for the speedy update!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Great plugin but doesn’t work on HTTPS unless you use this hack’ is closed to new replies.