Support » Plugin: Portfolio » Great plugin – but doesn’t work multilingually

  • This is a great plugin, which works perfectly in a monolingual setup. However, it would be great to get it to work multilingually, in conjunction with the widely used Polylang multilingual plugin. When creating a portfolio item it is necessary to be able to designate which language it relates to. This is currently not possible.

    Every portfolio should have a separate, distinct portfolio post for each of the languages in a multi-language site. Although it’s currently possible to link to a portfolio item in a specific language, that portfolio item will appear within a page in the default language for the website (so header and footer details will appear in the default language, not the language of the portfolio item).

    Would it be possible to adapt this plugin to work multilingually?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author RadiusTheme

    (@techlabpro1)

    Hello,

    Thanks for using our plugin.

    Yes sir plugin will work in Multilanguage. For each language you need to create item then create shortcode for each language and call the shortcode language wise.

    Thanks

    I’m sorry but I don’t understand your explanation. I would appreciate further clarification.

    The problem I’m having is that the URL of individual portfolio items is currently of the form http://www.domain.com/mypage regardless of the language of the portfolio item, when they need to be of the form http://www.domain.com/en/mypage to be able to display in the correct language (in this example english). Although I can create separate portfolio items for the different languages, they all lack the language code, located after the domain name. This is an issue for Polylang, but I guess it will be similar for qTranslate as well.

    I’ve found the solution for Polylang. Under Languages > Settings > Custom post types and Taxonomies > Settings I needed to tick the Portfolio box under Custom Post Types and tick the Portfolio Categories under Custom Taxonomies. Now works a charm.

    Great work! Perhaps it would be helpful to update your documentation to reflect how to use Portfolio in conjunction with Polylang.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.