Support » Plugin: Aesop Story Engine » Great plugin, but doesn't play nice with Dynamik

  • I really like this plugin, and think it represents some really great work on Nick’s part. What’s more, he has proven to be a very responsive developer. But unfortunately, the plugin doesn’t play nice with some themes. I use Genesis with the Dynamik child theme. Whether it is Genesis or Dynamik, I’m not sure, but after installing the 1.0 version of the plugin, I get the following error whenever I try to edit a post or page:

    “There was an error with your request.500”

    After Nick tried to solve this during the beta, he concluded it must be an incompatibility with the theme. I still hope he will be able to work with the Dynamik developers to solve this problem, because I think there is enormous potential in Aesop!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Nick Haskins

    (@nphaskins)

    Kinda bummed out that you rated this 4 stars on an issue that could very well not be my fault.

    That error you are showing above, is a different error than the one you originally reported here:
    https://github.com/bearded-avenger/aesop-core/issues/2

    Aesop is using a custom meta box class, so it’s come down to something in the meta box class that we’re using, or something within Dynamik.

    This the first, and only theme incompatibility that we’re currently aware of.

    I’d love to work with them to see what we can do, but I’d first need to get a copy of the theme. I’ll make it a point to pull this down this week and see what I find on my end.

    @cravenlovelace:
    Why not posting support request before if there are issues?

    Sorry, but I don’t understand this for such a new plugin, and even the whole area of themes is especially mentioned “as in work” in the description and in the FAQ. Found that a bit unfair to be honest.

    Thanks, Dave 🙂

    First off, apologies to Nick — I didn’t know what to put for the “stars” rating, I didn’t even *want* to put a stars rating, but the WordPress reviews mechanism won’t allow for otherwise — and if I can modify it, I will. I love what I’ve been able to see of Aesop, and I appreciate Nick’s quick responsiveness.

    Dave, I *did* post a support request to Nick’s Github support area when the problem first arose, and Nick valiantly tried to help, but was unable to. I’m not trying to cause any problems for Nick or his plugin!

    And yes, it’s a different error since I upgraded to 1.0. Nothing else has changed, to my knowledge; the last Dynamik update was before the last time I upgraded the Aesop beta.

    @cravenlovelace:
    Ah, sorry, was fault on my end, I didn’t see the Github first — if I could edit or delete my post here… but sorry!
    Just came across the plugin release here and was browsing through all pages…

    Thanks, Dave.

    Plugin Author Nick Haskins

    (@nphaskins)

    OK folks all good. I’ll get my hands on a copy of this and if there’s anything I can change, I will.

    I must say we’re using this meta box class exactly how it was intended to be used so I’m eager to see what the issue is, and more importantly, if I can replicate it.

    So I went ahead and contacted Cobalt Apps, the developers of Dynamik, about this problem today, and got the following response. I’m forwarding it here in the hope that maybe it helps track down the problem:

    I’m certainly happy to help, but from what I can tell this is ultimately an issue with the Plugin as my PHP log (after reproducing the issue on my end) spits out this error:

    “PHP Fatal error: Class name must be a valid object or a string in /Applications/MAMP/htdocs/catalyst/wp-content/plugins/aesop-story-engine/admin/includes/custom-meta-boxes/class.cmb-meta-box.php on line 82”

    I was able to pinpoint the Dynamik feature that is in conflict here, which is the In-Post Custom Lables option. It uses open source code called “Custom Metaboxes and Fields for WordPress” found here:

    http://github.com/jaredatch/Custom-Metaboxes-and-Fields-for-WordPress

    That appears to be the code that’s conflicting, as far as I can tell.

    Plugin Author Nick Haskins

    (@nphaskins)

    I see exactly what is going on here.

    We use the fork, of Custom Metaboxes, which is vastly improved with a lot more features such as repeatable, drag/drop fields.
    https://github.com/humanmade/Custom-Meta-Boxes

    Dynamik is using the original version
    https://github.com/WebDevStudios/Custom-Metaboxes-and-Fields-for-WordPress

    Those 2 forks are not compatible with each other. The only way this will be solved is if one of us removes the library. I can say that this is something we’re looking into in a future version, solely for the purpose of cutting down weight and optimizing.

    Thanks, Nick. I hope that happens, as I cannot wait to rip into Aesop!

    I spent some time today trying a work-around by installing a plugin that allows the use of other themes for certain pages, but it was to no avail, as just having the Aesop plugin activated makes the pages uneditable even if they’ve had another theme assigned. 🙁

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Great plugin, but doesn't play nice with Dynamik’ is closed to new replies.