Support » Plugin: Google Maps - Google Maps Builder for WordPress » Great plugin, but 3 issues: mouse wheel zoom, infowindow text and circle address

  • Resolved wpblogwriter

    (@wpblogwriter)


    Hello,

    Here my three issues:

    1) There is no option to disable zoom function with mouse wheel. This is important when embedding a map on a one-pager and there is content below the map

    2) The circle function is nice, but it doesn’t save the address given, it always gets back to default even though it stores the address somehow inside the widget code

    3) The description text in the info window displays escape codes when special chars are used like ‘ (which are frequent in certain languages like French).

    It is a nice plugin with lots of functions !

    Best regards,
    WBW

Viewing 6 replies - 1 through 6 (of 6 total)
  • Dear wpblogwriter,

    Thank you for contacting us.

    Can you, please, mention the version of the plugin you have?
    And also, please, send us your website link for us to check. In the case, if you do not want to publish your website link here, you can send it to our email info [at] huge-it.com.

    Looking forward to hearing from you soon.
    Best regards,

    Hello, sure I can do that. The site is in dev:
    https://bostores.environnement-test.fr/

    The strange thing is now, it shows the correct address. Is there some kind of delay/cached request? The second point isn’t an issue anymore..

    Best regards,
    WBW

    Dear wpblogwriter,

    It’s great. Thanks for keeping us updated about the results.
    And what about the escape codes? In the case, if you send us an email to info [at] huge-it.com, we can check it to understand the reason of the issue.
    Please, include this forum link and the plugin version you have to your email.

    Looking forward to hearing from you soon.
    Thank you

    I have installed the Version 2.2.4 of the plugin.
    You can see the escape code directly on the site I mentioned.

    … 33140 Villenave d\’Ornon Tel 06… there shouldn’t be a backslash..

    WBW

    Dear wpblogwriter,

    Please, be kindly informed that our developers can check the escape codes in the case if you send us an email to info [at] huge-it.com. We will be happy to investigate the case and assist you.

    Please, include this forum link to your email.
    Looking forward to hearing from you soon.
    Thanks

    Just an info to other users, in case they want to disable mouse wheel scrolling.

    A quick fix: add: “scrollwheel: false,” in the file frontend.js (plugin-directory/assets/js/frontend/) in the code block here:

    var frontEndMapOptions = {

    mapTypeId: google[‘maps’][‘MapTypeId’][‘ROADMAP’],
    scrollwheel: false,
    minZoom: dataMinZoom,
    maxZoom: dataMaxZoom
    };

    After doing the change, you need to save your widget once.

    Note that after a plugin update, this hack is deleted and you may need to update this line again.

    @huge IT: I believe this could be a nice feature for the plugin settings…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Great plugin, but 3 issues: mouse wheel zoom, infowindow text and circle address’ is closed to new replies.