Support » Plugin: PhastPress » Great but create concern on my website…

  • great plugin who improve really well the loading of my content but the contern is here :
    “You can enable text compression in your web server configuration.
    URL
    Transfer Size
    Potential Savings
    …phast.php/c2VydmljZ….q.js(www.website.com)
    140.5 KiB
    96 KiB
    …phast.php/c2VydmljZ….q.js(www.website.com)
    108.4 KiB
    64.9 KiB”

    It seem like the plugin use js whose are not previously compressed by brotli or gzip and i don’t know how to do it by myself. I use o2switch and it’s a hosting provider with brotli enable by default. And it’s really activated so i hope my comment can be considered for an update.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Albert Peschar

    (@kiboit)

    Hi @takasu,

    The plugin works well, you say, and you think it is a nice way to ask for support by leaving a three star review? The support forum is here.

    Anyway, responses from PhastPress should be gzip-compressed automatically. Is the “Enable gzip compression on processed resources” setting enabled?

    If that is the case, and the compression still doesn’t work, could you share the URL of your site?

    –Albert

    Plugin Author Albert Peschar

    (@kiboit)

    Hi @takasu,

    Someone else turned out to have the same issue with o2switch.

    It’s because their configuration does not optimize responses with the MIME type application/json, which PhastPress uses. I’ve released a new version of PhastPress that uses text/plain instead, which is automatically compressed to brotli or gzip by o2switch.

    If you’d still like to use PhastPress, you can update to version 1.98 and see if the compression issue is resolved.

    –Albert

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this review.