Support » Plugin: CKEditor WYSIWYG for Gravity Forms » gravityforms + custom post types conflict

  • Resolved rhust

    (@rhust)


    The CKEditor does not display on forms that use GF+CPT. And since I need the functionality of GF+CPT, I’m stuck… Goodbye CKEditor… I loved you more…

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author ovann86

    (@ovann86)

    Hey,

    Can you explain to me how it’s not working?

    I havent used Gravity Forms + Custom Post Types before, but I was able to install it and use it along with this plugin.

    I was able to setup the form and ‘CKEDITOR Enable’ the ‘post body’ field, then open the form, fill out some content, submit, then saw it as a post in the back end.

    Are you saying the form doesnt load at all when you tick the ‘ckeditor enable’ option? Or that CKeditor doesnt load?

    Do you know how to check a browser debug console? My guess is you’ll see a message in there letting you know the exact conflict.

    Thanks for getting back. You rock.

    If I have gf+cpt turned off, the CKEditor features are visible on frontend forms. And no errors. After turning it back on and inspecting the errors I was able to track down a custom taxonomy that had been malformed when input through GF+CPT. It was causing a “>” to be out of place when CKEditor was being rendered.

    – Rob

    Plugin Author ovann86

    (@ovann86)

    That’s awesome to hear. Let me know if there’s anything else I can do to help make them play nicely together.

    Adding … in case I or someone else refers to this in the future, it was an encoding issue (I assume in the CPT slug or name) the ‘greater than’ symbol was being handled using the encoded value of & gt; rather than the actual value >

    • This reply was modified 2 years, 9 months ago by ovann86.
    • This reply was modified 2 years, 9 months ago by ovann86.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘gravityforms + custom post types conflict’ is closed to new replies.