Support » Fixing WordPress » Gravity Forms slows down the admin area

  • Resolved robmin

    (@robsticles)


    Gravity Forms is slowing down my admin area. I have disabled all other plugins, reverted to a default theme (Twentysixteen), and still enabling Gravity Forms slows down the back-end.

    I installed Query Monitor to try find the problem. It looks like HTTP POST requests to https://www.gravityhelp.com/wp-content/plugins/gravitymanager/version.php are taking about 1 second each. I am seeing up to 40 requests to this file with Gravity Forms and all the add-ons I’m using.

    The support guys asked me to install Transients Manager and to delete expired transients, because they suspect another plugin is corrupting the transients, but this is not the case.

    Another user on the forums confirmed the problem, and resolved the issue by rolling back to WP 4.5.2.

    It seems the issue arose after updating to WP 4.6.

    I currently have installed:

    PHP Version: 5.5.9
    MySQL Version: 5.5.47
    WordPress Version: 4.6.1
    Gravity Forms Version: 2.0.7

    Some help here would be much appreciated.

Viewing 15 replies - 1 through 15 (of 18 total)
  • windyjonas

    (@windyjonas)

    I have the same problem, for a single admin page there are 11 HTTP POST requests to
    https://www.gravityhelp.com/wp-content/plugins/gravitymanager/version.php. On some of the admin pages I get 25 such requests.
    From Query Monitor

    Thread Starter robmin

    (@robsticles)

    @windyjonas would you mind sharing your server configuration? You can find PHP/MySQL/GF/WP details under Forms > Settings > Installation Status.

    Apparently downgrading WordPress v4.5.2 fixes it.

    windyjonas

    (@windyjonas)

    @robmin sure:

    PHP-version 7.0.10-2+deb.sury.org~trusty+1
    MySQL-version 5.5.50
    WordPress-version 4.6.1
    Gravity Forms Version 2.0.7.2

    Thread Starter robmin

    (@robsticles)

    @windyjonas It looks like WP 4.6 upgrade is the common factor. Are you using Apache or Nginx?

    windyjonas

    (@windyjonas)

    @robmin Apache/2.4.7 (Ubuntu)

    Thread Starter robmin

    (@robsticles)

    @windyjonas Same here.

    Any luck? I’m having the same issue since switching from Apache to Nginx. As soon as I disable Gravity Forms everything speeds up.

    Thread Starter robmin

    (@robsticles)

    Nope, I haven’t had time to look into it further. I’m planning on following up later this week with the GF support folks.

    Check if Curl is installed on the server. It might have been a coincidence, but as soon as we installed Curl this issue stopped occurring.

    Thread Starter robmin

    (@robsticles)

    Must have been a coincidence. I have curl installed 🙁

    Ok I’ll check my setup to see if anything else changed.

    Thread Starter robmin

    (@robsticles)

    I have tried optimising the database with WP-Optimize and I went ahead and removed transient options and that hasn’t fixed it either. I might just do a reinstall over Christmas because I can’t seem to get it fixed any other way.

    I fixed this issue by comment out the call to post_to_manager on line 2101 in gravityforms/common.php:

    $raw_response = ''; //self::post_to_manager( 'version.php', $nocache, $options );

    Until this is resolved by Gravityforms..

    Thread Starter robmin

    (@robsticles)

    Thanks for that @gerhardsletten. BTW, the GF dev team have acknowledged the issue and are working on a fix.

    I noticed that disabling w3tc object cache “fixes” the problem. That is, the http requests to gravityhelp.com doesn’t occur for every admin page. For my site that reduced the page load time from seven seconds to one”

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Gravity Forms slows down the admin area’ is closed to new replies.