Support » Plugin: Post SMTP Mailer/Email Log » Gravity Forms multipart message

  • First of all, thanks for a great plugin. Recently, I started improving the email-deliverability of my Gravity Forms notifications. One of the improvements is to make use of a multipart message format. For that, I make use of the “4. Change the message format” at https://docs.gravityforms.com/gform_notification/ documentation. I use that piece of code to change it to “multipart”. The code works fine and will sent the notification as a multipart message. The only problem is that the email_boundary code 394c21ef2c7143749256c37c3b5b7ee0, which i did find in the plugin files “gravityforms/common.php”, is added to the content of the email body on the bottom. It is visible when you read the message in a mail client. That email boundary code should only be in the email header.

    This email_boundary code is only added when I make use of the POST SMTP plugin and does not happen when I disable this plugin.

    Is there some kind of conflict/bug between those plugins? Any idea what causes the problem? Or is this something that cannot be fixed? Thanks a lot.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi,

    I can check it but only tomorrow, sorry!

    Thread Starter mizou

    (@mizou)

    Don’t worry. Tomorrow is great. Thanks a lot.

    Thread Starter mizou

    (@mizou)

    I was wondering if you had a look at it? A big thanks again.

    Thread Starter mizou

    (@mizou)

    Let me know if have any questions. This bug is still occuring.

    Hi,

    I worked hard on a feature that hopefully will resolve your issue and another stuff.

    Any chance you can try the dev version?

    Thread Starter mizou

    (@mizou)

    Amazing, yes, no problem at all. Let me know how I can access the dev version or what you need.

    Great!

    Please check carefully the returning email: from, to, reply-to, headers, etc…

    Here:
    https://downloads.wordpress.org/plugin/post-smtp.zip

    Thread Starter mizou

    (@mizou)

    I tried this dev-version, but the problem is still there. I don’t have knowledge technically to analyse the email header properly to make mistakes visible.

    Thanks.

    In settings (show all settings), Can you change the mailer type to phpmailer and try again?

    Thread Starter mizou

    (@mizou)

    Sorry for the late reply, I was really busy. But I tested with your dev-version and making use of the PHPMailer solves the issue I was talking about.

    I can imagine it would be better to make use of the PostSMTP mailer ideally.

    First, I’m glad it worked.

    Second, my intention is to make phpmailer the primary one and the only one.

    For now, there are two because I want to be sure it’s working perfectly before remove the other one.

    Please notice: for now, the fallback option is not working with phpmailer type.

    Thread Starter mizou

    (@mizou)

    Thanks a lot! Get it. I will keep an eye on the official plugin update.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Gravity Forms multipart message’ is closed to new replies.