Support » Plugin: Gravity Forms Directory » Gravity form doesn’t show when using conditional logic

  • When I use conditional logic the form doesn’t show. But as soon I remove it it works just fine.
    Any help, please!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Tonywho

    (@tonywho)

    Me as well, three GRAVITY FORMS support members still testing:
    __________________________________________

    “Because your form uses conditional logic it has an inline style of display:none applied, if your page has any JavaScript issues they can prevent the Gravity Forms scripts from running, and when those scripts can’t run the inline display:none style can’t be removed.

    You’ll want to run through a full theme/plugin conflict test: https://docs.gravityforms.com/testing-for-a-themeplugin-conflict/

    Regards,

    Richard Wawrzyniak”

    __________________________________________

    Winstead999 replied
    Feb 16, 1:11pm
    so to fix? running twenty seventeen, your plugin running alone still fails.
    sooo remove all conditional logic from your example employment application?

    __________________________________________

    “Your page doesn’t load any Gravity Forms scripts or styles. This can happen if the theme doesn’t have the wp_head function in the header. Can you make sure you are using the default unmodified twenty-nineteen theme for testing?

    Regards,
    Ajay Verma”

    __________________________________________

    “As Ajay mentioned the Gravity Forms style files are not added to your page, so the styles applied to the form currently are the ones applied by the theme and Elementor. Please double check that you have the Output CSS setting in Forms -> Settings set to On.

    There’s also a jQuery error in your page https://www.dropbox.com/s/3oueok6mgqtvvoa/2019-2470-11fe13df-6441-407e-bca9-2a4cbff7799a.png?dl=0 this can be caused by the plugin SG Optmizer, try disabling it and clearing your browser cache.”

    __________________________________________

    Winstead999 replied
    Feb 18, 10:36am
    Where to begin, I checked it incognito to see results, no luck. I disabled
    SG optimizer with no effect, as I have explained to you all, I have a form
    on there that has no bullets, and one that does, so the theme caused one
    form to have the bullets and one not to huh?

    __________________________________________

    Hi Anthony,

    With more than 2 million of active GF installations, we don’t have any other active ticket of users experiencing this issue, just your ticket, and we can’t replicate it either in our testing sites. So all points to something in your site setup.

    If you send us a temporary WP administrator login and complete (S)FTP details (host, port, encryption, username and password). We’ll be happy to take a closer look into your site to find the source of the issue.

    Regards,

    __________________________________________

    Samuel Aguilera

    • This reply was modified 7 months ago by  Tonywho.
    Tonywho

    (@tonywho)

    I sent them a link to this support log, so they can see I am not the only one and they did poor checking.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Gravity form doesn’t show when using conditional logic’ is closed to new replies.