Support » Plugin: W3 Total Cache » Gravity Form Conflict

  • Resolved hypevent

    (@hypevent)


    Since W3 Total Cache updated, my gravity form has had an issue. Whenever I complete a form, I get redirected back to the first page to start the form again (all the data/answers are saved when I start at the 1st page again. I know that this is a W3 Total Cache because I have disabled the plugin and I no longer have an issue.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @hypevent

    I am sorry about the issue you are experiencing and I am happy to assist you with this.
    Can you please disable W3 Total Cache settings one by one in Performance>General settings, save and purge the cache after each and see which one might be causing the issue?
    Thank you.

    Thread Starter hypevent

    (@hypevent)

    That would take me hours to do because the form I have is very long. Can you give me some suggestions that would save me time?

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @hypevent

    I am sorry I did not realize that.
    Please try to disable Minify, save all settings and purge caches. See if the issue persists! If so, you can exclude that page from being minified by adding:
    /your-gravity-form-page/ to Perfromance>Minify>Advanced, “Never minify following pages” or you can exclude Gravity form CSS and JS file from being minified in Performance>Minify, advanced sub-box “Never minify the following JS files:” and “Never minify the following JS files:”
    I believe those files are as listed below but please check this first:
    wp-content/plugins/gravityforms/css/formreset.css
    wp-content/plugins/gravityforms/css/datepicker.css
    wp-content/plugins/gravityforms/css/formsmain.css
    wp-content/plugins/gravityforms/css/browsers.css
    wp-content/plugins/gravityforms/js/gravityforms.js
    I hope this helps!

    I am having the exact same issue since updating W3 Total Cache on all my sites. I have done the work listed above and isolated it to the Minify functionality.

    Minify was previously set up to not minify the pages and scripts as listed above, but since the most recent update there are conflicts once again when Minify is turned on. Previously it worked without errors, but since updating a few days ago all Gravity Forms functionality is now disabled.

    The only setting that directly affects whether Gravity Forms works or doesn’t work is HTML Minify Enabled/Disabled. Turning JS or CSS Minify on/off does not affect functionality. Even enabling or disabling the sub-items in that HTML category such as Inline CSS, Inline JS, and Line Break Removal has no effect on it.

    Let me know what can be done to fix this. Thanks!

    • This reply was modified 2 years, 12 months ago by dletell.
    Thread Starter hypevent

    (@hypevent)

    Unfortunately, making the suggested changes did not work. What else can you suggest?

    The latest W3TC definitely broke GravityForms. And this has nothing to do with minification, since I am not minifying GF.

    As soon as I reverted back to 10.2, everything started working again. Whatever changes you’ve implemented since the last release broke GF.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @megaz @hypevent @dletell

    @dletell just to confirm, if you disable HTML minify GF is working as expected?

    @megaz @hypevent Can you please disable HTML minify and see if the issue persists?

    That would be correct from my end, though other people are having the same issue from all different causes as far as I can tell.

    @megaz what would be the best way to roll back to an earlier version?

    • This reply was modified 2 years, 11 months ago by dletell.
    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @dletell

    Can you please apply this fix:
    and replace line 356 in lib/Minify/Minify/HTML.php
    if ( empty( $m[3] ) ) {
    with
    if ( $m[3] === '' ) {
    Please let us know if this helps!

    Just wanted to chime in and confirm that since the most recent update, any gravity forms which usually use google’s recaptcha feature does not permit the form to submit.

    Two work arounds:
    – Disabling the recaptcha allows the form to send (not ideal).
    – Keeping recaptcha enabled while disabling W3 Total Cache also fixes it.

    As Marko suggested I cleared the cache, updated said HTML.php file, reloaded and recleared the cache and attempted to submit the form again with recaptcha enabled on it.

    IT WORKED! Hope this gets submitted as a solution soon for the next release. I appreciate your time and attention Marko!

    Forgot to tag you @vmarko

    @vmarko This did fix the issue for me and Gravity Forms works properly now. Thanks!

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @dletell @endurox

    I am glad this fixes your issue!
    Thank you!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Gravity Form Conflict’ is closed to new replies.