Support » Plugin: Pods Gravity Forms Add-On » Gravity File Upload or Post Image (Featured) don’t work

  • Resolved boonika

    (@boonika)


    Gravity Forms File Upload and Post Image (Featured or not) don’t work. I checked all the threads that have been started because of the same problem and it looks like it was never resolved.

    If I use GF File Upload field and connect it to Pods file/image/video field, upon submitting the form I get “(pods field name) is empty” error message. The funny thing is that there is also another File Upload field, below the first one, but it is set as Multi-File upload, just as well as the Pods file/image/video field that it is linked to. I don’t get errors for that field.

    If I use GF Post Image field (Featured or not) and set Advanced Pod Settings to support Featured Field, I don’t get any error, but the image is not uploaded and set as featured. I can only do it later in the backend, manually.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jim True

    (@jimtrue)

    I just tested this locally with File Upload field mapped to Featured Image and this worked flawlessly. You can’t use the Post Fields, Featured Image, as you’re correct, that doesn’t work mapped to Featured Image. I also tested single file and multiple file upload and they both worked flawlessly.

    I’m using the following versions:

    Gravity Forms 2.2.6
    Pods 2.7.1
    Pods Gravity Forms Add-on 1.3

    What are you using on your end?

    Thread Starter boonika

    (@boonika)

    Jim, thanks so much for taking time to do extra testing. Not sure why it won’t work for me. I will try again. Do you think it is possible to produce such problems if new Pods field was created and connected later after the previous GF and Pods custom field connections have already been established?

    Plugin Author Jim True

    (@jimtrue)

    That shouldn’t matter, but you might have to recreate your feed. It doesn’t sound like the issue is with your field, though, it sounds like the issue is with the Featured Image.

    On my test above, I actually did the Featured Image first and then went back in and created a Single and Multiple Image upload fields and added those to the form and mapped them. So no, it shouldn’t matter about editing them after the fact.

    Thread Starter boonika

    (@boonika)

    Thanks once again. Much obliged. So when you say “I actually did the Featured Image first…” are you actually saying that you have checked that Featured Image option in the Pods Advanced Settings? I have that option checked. Then you connect the GF Upload Field to that WP field, right?

    Thread Starter boonika

    (@boonika)

    OK, it is working now but now there is a problem with taxonomies. I will write another support post about it.

    Plugin Author Jim True

    (@jimtrue)

    Okay, I’m marking this one resolved.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Gravity File Upload or Post Image (Featured) don’t work’ is closed to new replies.