Support » Plugin: Optimum Gravatar Cache » Gravatars still showing as url redirects on YSlow

  • Resolved brewsi

    (@brewsi)


    Hi there. I have installed the plugin and set up accordingly but on Gtmetrix the gravatars are stil redirecting to the external site as opposed to the cached image. Is there something I’m missing?

    Thanks

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author José Miguel

    (@jomisica)

    Hello @brewsi,

    In the beginning it is normal to continue to present the gravatars of gravatar.com. Because the cached gravatars are rendered in the background by WP Cron.

    Give the plugin some time to process the gravatars. If some time has passed and the plugin continues to display gravatar.com from gravatar.com. See if you have WP Cron active on your site.

    However I believe it is the UsersWP plugin that is interfering.

    I do not know the UsersWP plugin I will analyze.

    Plugin Author José Miguel

    (@jomisica)

    Bello @brewsi,

    The UsersWP plugin does not interfere with gravatar resolution. (Tested).

    I even liked the plugin and I’m going to use it.

    Plugin Author José Miguel

    (@jomisica)

    Activate and configure the plugin and let it run for a while for the cache to be created in the background.

    Thanks Jose

    Can I ask how long is a while as I have had the plugin active for over a week?

    Thanks

    Plugin Author José Miguel

    (@jomisica)

    Hello @brewsi

    “A while” depends on the values you entered in the cache page.

    What values did you insert into the cache page?

    Is WP Cron active on your site?

    Hi jose,

    I set it for 5 days but I’m still.seeing the

    //www.gravatar.com/avatar/17daf12a1a63015ec396fd5c1a09db36?… redirects to https://i1.wp.com/…/no_profile.png?..

    Repeated on avoid URL redirects on GTmetrix

    Am I doing something wrong ?

    Thanks

    Plugin Author José Miguel

    (@jomisica)

    Hello @brewsi

    Please send a screenshot of the cache configuration page.

    Plugin Author José Miguel

    (@jomisica)

    Have you tried clearing the cache of other full page cache plugins (WP Super Cache, for example)?

    Have you checked if the images were created in the cache directory that is configured?

    hi Jose,

    In the cache where would i see the images?

    Als there is only 1 image showing as cached

    you can see the screenshot of configuration here

    https://screenshot.net/w97nncm

    Thanks for your help with this.

    Plugin Author José Miguel

    (@jomisica)

    The cache directory https://herbitravel.com/wp-content/uploads/optimum-gravate-cache/ does not exist.

    However I see that by screeshot there are 24 images.

    Do you see any error messages when you save the options?

    Hi jose,

    I see no error messages when saving.
    There are 24 images cached on the plugin.

    On GTmetrix the URL redirects for gravatrs are all for “no image PNG” even though I have set a default.

    Plugin Author José Miguel

    (@jomisica)

    Hello, the redirects you see in gtmetrix are not produced by the OGC plugin but by the userswp plugin.

    The default gravatar for OGC plugin will always be served from the configured cache.

    Try to disable all plugins to see if there is any incompatibility.

    The plugin does not work without the cache directory.

    Plugin Author José Miguel

    (@jomisica)

    Hi @brewsi

    According to the screenshot that you sent from your settings, the URL to the OGC Plugin cache directory must be this:
    https://herbitravel.com/wp-content/uploads/optimum-gravatar-cache/.

    However this directory does not exist as you can see from the following screenshot:
    https://snag.gy/ITZSR0.jpg

    The plugin is prepared to do nothing if the cache directory does not exist. So the OGC plugin can not be redirecting to nowhere.

    I have to close this ticket. Because the problem you present has nothing to do with this plugin.

    First configure the plugin. If you need help setting up the plugin open another topic related to the plugin problem.

    Thank you.

    brewsi

    (@brewsi)

    Thanks Jose

    Plugin Author José Miguel

    (@jomisica)

    Hello @brewsi

    After all it’s really the usersWP plugin that is making it impossible for other plugins to work with the gravatars.

    If you disable the usersWP plugin you will find that the Optimum Gravatar Cache works perfectly.

    At the moment I have no ideal solution to solve the situation. I will try to contact the usersWP developer later.

    However I have a functional solution, but you have to add the following line of code to the OGC plugin file on line 159.

    
    remove_all_filters('get_avatar');
    

    Any doubts, say it!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Gravatars still showing as url redirects on YSlow’ is closed to new replies.