Support » Plugin: WP User Avatar » Gravatars not showing up even though settings are correct

  • For some reason, users’ gravatars are not showing up on the site, even though I have set up the settings as you suggest with avatar settings to *not* disable gravatars. The odd thing is that for a user’s account who uses gravatar when they go to edit their profile image, it shows the gravatar on the edit page, but not the actual listing page.

    A user profile, for example, that *should* be showing a gravatar is at https://newenglandfilm.com/members/michele

    Thanks for any help!

    Here’s the code of that page.

    <div id="item-header" role="complementary">
    			<h3 class="sing-tit">
    					<a href="<?php echo get_author_posts_url($author_id);?>"><?php echo get_the_author_meta('display_name', $author_id);?></a>
    					<?php if ( $author_id == $current_user_id ) : ?>
    					<a class="edit-profile-link" href="<?php echo get_author_posts_url($author_id);?>/edit-profile">(Edit Profile)</a>
    					<?php endif;?>
    			</h3>
    		
    		
    			<div id="item-header-avatar">
    				<?php if ( $author_id == $current_user_id ) : ?>
    				<a class="profile-pic-edit-button" href="/edit-my-profile-photo"><i class="fa fa-camera"></i></a>
    				<?php endif;?>
    			
    				<?php echo get_avatar($author_id,150);?>
    			</div>	
    		
    			<div id="item-header-content">				
    					<p class="user-description">
    					<?php $user_meta = get_userdata($author_id);
    			echo($user_meta->description);
    					?>
    					</p>
    					
    		

    The page I need help with: [log in to see the link]

  • The topic ‘Gravatars not showing up even though settings are correct’ is closed to new replies.