Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Gravatar profile image not going away after the latest update

  • Joe Bloggs

    (@joe-bloggs)


    I started having an issue with the default Gravatar icon profile image of UM registered users.

    My WordPress settings are set to show the default Gravatar profile for users that didn’t upload the avatar, but it’s set to show the Mystery Man icon and it works just as expected for the comments.

    Until the most recent UM update, this was also working well for UM. Mystery Man was displaying across the site.

    After the update UM profiles now started to show the default Gravatar icon – the ugly G on the blue background.

    My WP settings are still the same, Mystery Man shows for comments, I even tried to upload a custom avatar icon in the UM settings.

    No matter what, G Gravatar icon is still showing up ignoring the custom profile avatar image in the UM settings.

    Anybody has similar issues?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @joe-bloggs,

    Do you have “Use Gravatars?” enabled and what “Use Gravatar builtin image” setting have you set? Please check settings in Ultimate member -> General -> Users section and if it helps.

    Regards.

    jhwest

    (@jhwest)

    Hey, Joe. This is the only way I can contact you so here goes. What plugin did you end up using to block key words from Gravity Forms, if you don’t mind?? 🙂

    Joe Bloggs

    (@joe-bloggs)

    @ultimatemembersupport

    Yes I do have the option to use Gravatars ticked, however I also have the “Mystery Man” icon chosen for the default Gravatar builtin image.
    But instead I am getting the Gravatar icon (the blue icon with the white G on it).

    There is also an option to upload a custom user profile image, tried that also, but again getting Gravatar icon instead.
    (not sure if the use of Gravatars must be switched off for this to work)

    I can confirm that all this was working just perfectly fine not a long ago, with the same settings, I haven’t really changed anything, the Mystery Man was showing fine.

    Joe Bloggs

    (@joe-bloggs)

    @jhwest

    For now my site is still in development with no messages coming in, so I’m not using any yet but you have a few options available.

    Option 1 is the WP Spamshield plugin.

    Option 2 is the use of Gravity Perks plugin with the the Gravity Forms Blacklist addon.

    Both of these two will connect to your default WP comment blacklist to filter out spam words.
    ( out of these two I’m probably heading for the Gravity Perks, although it comes with a higher price tag.)

    There is another option and that would be using the Akismet plugin. From what I could find, it works with Gravity Forms quite well.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.