Support » Fixing WordPress » Gravatar Not Showing – Please Help!

  • Resolved Daztaffyboyo

    (@daztaffyboyo)


    Hi guys, in my Dashboard/Discussion settings I have ‘show Avatars’ enabled (with the Gravatar icon set as default). In my Gravatar.com account my picture shows up ok against the same email address I use in my Dashboard/User/Profile.

    But when I look in Dashboard/Users my Gravatar doesn’t show up, only the default Gravatar icon (it’s the same in my posts)?

    Please could someone help.

    Many thanks, Taffy.

Viewing 2 replies - 1 through 2 (of 2 total)
  • I wish I could help, but I’m here looking for a similar answer. My gravatar shows up correctly in comments on my public site (and here, see at left), but still displays my old photo on my dashboard. I even deleted that photo at gravatar’s site, but somehow it keeps appearing on my dashboard.

    I fixed it on mine. The problem was not Gravatar, WordPress, or my Mac, but rather the Google Chrome browser. It seems that Chrome would not refresh the icon. It kept pulling it in from the cache. Firefox displayed correctly, which is what tipped me off to the problem being Chrome.

    To fix it, I cleared Chrome’s cache. Even then a page refresh didn’t work. I needed to close the tab, then go to my WordPress dashboard in a new tab to finally get my new avatar to show up.

    I hope this helps you, too.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Gravatar Not Showing – Please Help!’ is closed to new replies.