• Resolved Chris

    (@ru2cool)


    I’m currently using the standard gravatar image on my site for the profile picture. After activating the free smush plugin and setting it to compress all of my pictures, I noticed that the gravatar is completely missing from the author page. It re-appears after I disable the smush plugin. I also noticed that the miniature sized image disappears from the upper right portion of the toolbar when I’m logged in to wordpress to configure my site. I would greatly appreciate any help in resolving this issue.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @ru2cool

    I hope you’re well today!

    It seems that this is related to the theme and Lazy Load. To confirm that: could you please enable Smush on site but then go to “Smush -> Dashboard -> Lazy Load” and disable its “Lazy Load” feature there?

    After that, please clear cache on site and see if the gravatar shows up again. If yes, could you please double-check if you theme (or some other plugin) also has some sort of “Lazy load” feature enabled and if so disable it and try enabling Smush lazy load again?

    Let us know about results of that test, please.

    Kind regards,
    Adam

    I disabled lazy load in the smush plugin, refreshed the site cache using the hummingbird plugin, and the gravatar showed back up. Before attempting anything else, I disabled all of my plugins except smush and hummingbird. I’m currently using the free version of GeneratePress for my theme and I couldn’t find any settings pertaining to lazy load. So, I tried switching to the 2019 default wordpress theme and the miniature gravatar image was still missing from the toolbar. That theme didn’t display the gravatar on the author page at all.

    I did some more digging to make sure I wasn’t missing any settings for my theme and found this post in the generatepress forums. It would appear that they do not have a lazy load feature built into the theme.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @ru2cool,

    Please disable lazy loading so the gravatar is showing, or post a screenshot of the correct gravatar code so we can try and replicate this.

    Best regards,
    Anton

    I disabled lazy loading and the gravatar is visible now.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @ru2cool,

    I can see the issue. It will be resolved in the upcoming update. For now, as a temp solution, you can exclude gravatars from lazy loading by adding the class .avatar to the Classes & IDs exclusion list in Smush Lazy Load module.

    Best regards,
    Anton

    Hi Anton,

    happy New Year!

    I have the same issue as Chris but with the Storefront theme from WooThemes.
    I have added the class .avatar in the exclusion list in Smush Lazy Load module as you suggested.

    I have seen that a couple of maintenance releases have been released since your last reply but this issue is not resolved.

    Do you have a ETA for the fix? Thanks in advance.

    Cheers,
    A

    • This reply was modified 6 months, 1 week ago by decarvalhoaa.
    Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @decarvalhoaa,

    Thanks. And a happy New Year to you as well!

    We’re going to release an update on Monday. The free version will follow a few days after that.

    Best regards,
    Anton

    Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @ru2cool

    I hope you are doing well!

    We haven’t heard back from you for a while now so we’ve marked this ticket as resolved. If you do have any followup questions or require further assistance feel free to reopen it and let us know here.

    Kind regards,
    Nastia

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.