Support » Plugin: Optimum Gravatar Cache » Gravatar cache doesn’t seem to be updating based on the frequency set

  • ResolvedPlugin Contributor Will Stocks

    (@willstockstech)


    Hey @jomisica

    I hope you are well?

    I changed my Gravatar image late last week to a new image. I was expecting to see this reflected on my site within a day or two (I have the “check for outdated gravatars” set to every 1 day and check every 5 minutes), however it did not update!

    I thought maybe it was something to do with my site’s caching plugin, so I cleared my site cache – no change.

    I tried “sync users and commenters now” in the plugin – nothing happened at all.

    I then had to clear the gravatar cache (the button is/was disabled for some reason, so I enabled the button by editing the html and removing disabled=”disabled”) which meant I could click the button and the cache then emptied.

    My new gravatar then started to show and started caching (although I had to navigate through all pages that have a gravatar for it to cache each correct image).

    Any idea why this would/did happen?

Viewing 5 replies - 46 through 50 (of 50 total)
  • Plugin Author José Miguel

    (@jomisica)

    Technically in terms of implementing day or hours is basically the same thing.

    But I decided days at the beginning of the project, based on the analysis I made of both my users and users on other sites.

    Unfortunately many people do not create an account in Gravatar and the ones they create do not change their profile image every day. The most normal is to change from months to months.

    This is the reason I chose days.

    Plugin Contributor Will Stocks

    (@willstockstech)

    Very good point – very true. Changes would be reflected pretty quickly as well (unless a caching plugin is interfering) as I imagine most people will just leave it at a default of 1 day!

    Plugin Author José Miguel

    (@jomisica)

    As for the date and time for example:

    You configure ‘Refresh Gravatar cache every 1 day’ whenever WP Cron runs the task of the plugin that is configured with the option ‘Check for outdated Gravatars every 5 minutes’ the number of users that you configure in the’ Number of users to check simultaneously 10 users’.

    Of course if you set the ‘Number of users to check simultaneously’ option with a number greater than the number of (users that your site has as well as commentators), they will all be updated at once, and in this way it was possible know when the next task “Gravatar Cache Refresh” would happen.

    But the idea is to give control to the user to control these variables to fit your site / resources.

    WP Cron is not very precise when it runs the tasks. If your site has visits every second is acceptable, otherwise it does not always run the tasks at the desired time: https://developer.wordpress.org/plugins/cron/

    If you want something more accurate it is better to configure the tasks to run through the system cron: https://easyengine.io/tutorials/wordpress/wp-cron-crontab/

    Plugin Author José Miguel

    (@jomisica)

    Hello Will Stocks @willstockstech,

    I really appreciate your interest in the plugin as I told you.

    But to be more objective in the issues is better to open a new topic per issue.

    Plugin Contributor Will Stocks

    (@willstockstech)

    Ah yes – sorry! I get distracted haha.

    I think the original issue is now “basically” resolved – Hummingbird holds on to the old gravatars in its page cache, so when I clear that now it appears to update as expected.

Viewing 5 replies - 46 through 50 (of 50 total)
  • The topic ‘Gravatar cache doesn’t seem to be updating based on the frequency set’ is closed to new replies.