Support » Theme: Graphene » Graphene 2.0 messed up all!

  • Resolved ilkka ahmavaara

    (@ilkka-ahmavaara)


    Hi!

    Is there any place to roll Back to previous Graphene version. Updating to 2.0 messed up my whole page! There seems to be too much work to get it working under 2.0, mayยดbe I could do it later when I have time.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • This morning I had fatal errors on the sites that were automatically upgraded. I had to fix the code by hand and now my sites look all jumbled ๐Ÿ™

    A rollback would be great!

    I found one rollback and used it, from here: http://themecheck.org/score/wordpress-theme-graphene.html

    In ftp I took copy of existing Graphene theme, unistalled it in WordPress, then run setup of this zip file and mostly all came back as it is.

    My own CSS codes disappeared, but i had a copy of them. Also Grapahene visual settings needed configuration, colors and column width settings. Action hooks are as they were.

    It seems to me, that 2.0 is NOT ja Graphene update – it is totally different theme!

    Thank you! I did the same and all is good for now. True, it is a different theme!

    Thanks again.

    Theme Author silverks

    (@silverks)

    Rest assured, it is still the same theme.

    However, significant changes were required in order to bring features that are now a necessity in these days and age. An example of these features is responsive layout – the theme now adapts automatically to mobile devices, no matter their screen sizes.

    Because of the significant changes, there are bound to be some conflicts with heavily customised sites. However, with a little effort, those conflicts can be resolved by updating your custom CSS codes to accommodate the changes in this latest version.

    If you could not afford the time and effort to update your own customisations at this moment, you could temporarily roll back to the previous version. Be reminded that you will lose out on significant features that Graphene 2.0 brings, and we could not afford to support legacy versions.

    Follow these steps to roll back to the previous version:

    1. Export the legacy Graphene settings from WP Admin > Appearance > Customize > Graphene: Utilities > Export legacy settings.
    2. Download previous Graphene version using this link: https://wordpress.org/themes/download/graphene.1.9.4.3.zip?nostats=1
    3. Remove Graphene 2.0 and install Graphene 1.9.4.3.
    4. Go to Graphene Options, and import the legacy settings you have exported in step 1.
    • This reply was modified 8 months, 1 week ago by  silverks.

    Thanks for the explanation and hints. I have always thought, that it is mobile technology developers whos job is to create better technology to visualize web pages on mobile platforms. It would be lesser work, than code all the millions webpages in the world for their needs. Unfortunately it seems that mobiletechnology does not change or develop in this way, so webpages must.

    I couldn’t even access WordPress admin. The problem has since been solved. My host updated PHP from 5.4 to 5.6 and that solved it.

    This was the error I got.

    Fatal error: Can’t use function return value in write context in /home/t1000o5/public_html/wp-content/themes/graphene/admin/customizer/options-import.php on line 155

    • This reply was modified 8 months, 1 week ago by  notphotomatt.
    • This reply was modified 8 months, 1 week ago by  notphotomatt.
    • This reply was modified 8 months, 1 week ago by  notphotomatt.
    Theme Author silverks

    (@silverks)

    @notphotomatt, your issue is likely due to your server using an old, unsupported version of PHP (older than version 5.5). We’ll be releasing an update shortly which should fix the issue.

    Simply download the updated version (2.0.1) and replace the Graphene files that you have on the server via FTP. Let me know how it goes.

    Problem:
    I made the following change:

    Main content wrapper background: Gray

    Post and pages content background: White (This is the default) However, all the posts are showing up gray based on MAIN CONTENT WRAPPER BACKGROUND. Instead of white boxes surrounded by gray.

    Also where do we change the font? Thought there was an easy way to do it without having to customize the CSS under “Additional CSS”. Thanks.

    • This reply was modified 8 months, 1 week ago by  notphotomatt.

    Once the code is working for us on 5.4 php and we are able to upgrade, 2.0.1 works nicely, with minimal customization.

    And the new theme is very lovely. I had a panic attack this morning, and still lots to do, but it is very lovely ๐Ÿ˜€

    Hello

    To begin with I am sorry for my English, I feel that you will understand even my request.

    this asfternoon I see on my site an update of my theme fetish graphene. So I have to click on the update and I did not know that this was the beginning of the problems ….
    I have solved practically all the problems I had except one .. And you suspect that I am here for the one ๐Ÿ™‚
    So on my site I create small php programs that manage tables in my database. I have incorporated them into my site thanks to a “tip that I find on a site (I know what purists here will say, it’s apparently not very clean but I try to integrate them as add on and I never succeeded) So I use the tip noted here https://wpchannel.com/integrer-script-php-external-site-wordpress/ and it worked pretty well.
    Until today or I have a display problem, the best is to give you the link to see it:

    http://www.mediumnitemagnetisme.org/donnees_ange.php

    My 2 summary bars no longer looks like anything ๐Ÿ™

    What disrupts me is that it does the same on this 2nd script:

    http://www.mediumnitemagnetisme.org/formulaire_priere.php

    but on this one:

    http://www.mediumnitemagnetisme.org/test-tirage.php

    No worries, while they use the 3 of the trick I mentioned above. The only difference between the 3 is that the first 2 will type in a table in my database, so they have an include (“loginpriere.php”); while the 3rd does just the calculation and send the result in email.

    The problem is that as long as I had the previous version of my theme, everything went smoothly, my summary bars were normal. It’s just since this new version 2.0.1 that the bars are long like this. As if they were repeated a number of times.
    Would anyone have an idea? I know that absolutely it poses only an aesthetic problem, since it seems to work all the same, but it is the kind of thing that takes my head and prevents me from advancing.

    thank you in advance

    monsieurdnalgar

    (@monsieurdnalgar)

    RE. this advice: once prior version Graphene installed (1.9.4.3) there was no option to import legacy settings saved after upgrading to latest version. Everything is completely a mess at levantium.com (i was using a child theme). please help!

    Follow these steps to roll back to the previous version:

    Export the legacy Graphene settings from WP Admin > Appearance > Customize > Graphene: Utilities > Export legacy settings.
    Download previous Graphene version using this link: https://wordpress.org/themes/download/graphene.1.9.4.3.zip?nostats=1
    Remove Graphene 2.0 and install Graphene 1.9.4.3.
    Go to Graphene Options, and import the legacy settings you have exported in step 1.

    Greybox

    (@greybox)

    After updating from 1.9.4.3 to 2.0.2, my web site was dead (500 Internal Server Error). I could not even use admin mode until I restored from my latest backup. What is the proper way to upgrade if I use child theme (graphene-child)?

    Thank you.

    • This reply was modified 8 months ago by  Greybox.
    Theme Author silverks

    (@silverks)

    @greybox, what are the files that you have in your child theme?

    Theme Author silverks

    (@silverks)

    @monsieurdnalgar, you can import the legacy settings in 1.9.4.3 via the standard settings import feature, in Graphene Options page (bottom right of the page).

    Greybox

    (@greybox)

    I use eme.css, style.css and functions.php in graphene-child.

    I can export legacy settings from 1.9.4.3, but how can I import if the web site becomes dead after updating (500 Internal Server Error even in admin mode)? I can only use FTP to access the files after the update.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Graphene 2.0 messed up all!’ is closed to new replies.