Support » Plugin: Postman SMTP Mailer/Email Log » Grant permission with Google error

  • We are getting the following error:
    Error: redirect_uri_mismatch

    Application: Cornelis Grey Construction

    You can email the developer of this application at: info@cgreyconstruction.com

    The redirect URI in the request: http://cgreyconstruction.com/wp-admin/options-general.php?page=postman did not match a registered redirect URI.

    Learn more

    Request Details
    access_type=offline
    login_hint=infocgreyconstruction.com
    as=-39c2d03e58003eea
    approval_prompt=force
    hl=en
    scope=https://mail.google.com/
    response_type=code
    redirect_uri=http://cgreyconstruction.com/wp-admin/options-general.php?page=postman
    state=e4b61ce42f0d4f498642ee7ea5ec7f25
    from_login=1
    client_id=437915792867-pktopv099ahe332gsqvag1ko1n9rmpsa.apps.googleusercontent.com
    authuser=1

    What should i do to fix it?

    https://wordpress.org/plugins/postman-smtp/

Viewing 3 replies - 1 through 3 (of 3 total)
  • when Diagnostic test run:

    OS: Linux p3plcpnl0549.prod.phx3.secureserver.net 2.6.32-531.29.2.lve1.3.11.10.el6.x86_64 #1 SMP Fri Jun 12 15:09:02 EDT 2015 x86_64
    HTTP User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.101 Safari/537.36
    Platform: PHP Linux 5.4.43 / WordPress 4.3.1 en_US
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=Yes
    WordPress Theme: cgrey2015
    WordPress Plugins: AddToAny Share Buttons, Akismet, CMS Tree Page View, Contact Form 7 MailChimp Extension, Custom Background Extended, Duplicate Post, Enable Media Replace, Google Analytics by Yoast, Juicer, MailChimp Forms by MailMunch, Photo Gallery, PlanSo Forms, Postman SMTP, Regenerate Thumbnails, Simple Related Posts Widget, Sucuri Security – Auditing, Malware Scanner and Hardening, Testimonial Rotator, The Single Background, TinyMCE Advanced, Yoast SEO, WP Twitter Feeds
    Postman Version: 1.6.23
    Postman Sender Domain (Envelope|Message): cgreyconstruction.com|cgreyconstruction.com
    Postman Prevent Message Sender Override (Email|Name): No|No
    Postman Transport URI: smtp:tls:oauth2://smtp.gmail.com:25
    Postman Transport Status (Configured|Ready|Connected): Yes|No|Yes
    Postman Deliveries (Success|Fail): 0|0
    Postman Bind (Success|Fail|Path): No|No|/home/natashagrey/domains/cgreyconstruction.com/wp-includes/pluggable.php
    Postman TCP Timeout (Connection|Read): 10|60
    Postman Email Log (Enabled|Limit|Transcript Size): Yes|10|128
    Postman Run Mode: production
    Postman PHP LogLevel: 40000
    Postman Stealth Mode: No
    Postman File Locking (Enabled|Temp Dir): Yes|/tmp

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Go back into the Google console and make sure your Redirect URI exactly matches this:

    http://cgreyconstruction.com/wp-admin/options-general.php?page=postman

    Other conversations about your issue : https://wordpress.org/tags/redirect_uri_mismatch

    Google doesn’t allow a path (anymore?). The field description for Authorized Javascript Origins says: “Cannot contain a wildcard (http://*.example.com) or a path (http://example.com/subdir).”.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Grant permission with Google error’ is closed to new replies.