Support » Plugin: WooCommerce » Grant download permissions NOT working again

  • Resolved squilib

    (@squilib)


    The Grant permission problem was solved with Woocommerce 5.2.2

    Now back in Woocommerce 5.3.0, every time I try to grant download permission to a customer I get the following warning:

    Could not grant access – the user may already have permission for this file or billing email is not set. Ensure the billing email is set, and the order has been saved.

    Please, fix it soon.
    Thank you

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter squilib

    (@squilib)

    Please, someone can help me how to restore the version 5.2.2 without losing my orders?
    Thank you

    • This reply was modified 8 months, 2 weeks ago by squilib.
    Plugin Support Sunday Ukafia (a11n)

    (@sukafia)

    Hi @squilib,

    Did you look into the suggestion by the notice? Also, are you by any chance using a plugin to manage downloads?

    Could you please check if the issue persists with the Storefront theme activated and all plugins except for WooCommerce deactivated? You’ll find a detailed guide to do a conflict test here: https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    If you can’t do this on your live site, I’d recommend creating a staging site. If your host doesn’t offer that option, we recommend WP Staging for quickly spinning up a new test site: https://wordpress.org/plugins/wp-staging

    Let me know what you find so I can help further!

    Thread Starter squilib

    (@squilib)

    Thanks, Sunday Ukafia, but I just got a confirmation that this is a bug and will be fixed in the next release of WooCommerce core. (from Happiness Engineers @automattic)

    Plugin Support gabrielfuentes

    (@gabrielfuentes)

    Hi there!

    Indeed! You can see the bug here:

    https://github.com/woocommerce/woocommerce/issues/29884

    Please feel free to go ahead and add your own comment to the thread if you can. This will give the developers a good idea of the size and impacts of the issue and will be resolved there.

    Thank you! 🙂

    Yes, this bug is back in Woocommerce version 5.3. There is a good workaround from Tammullen here: https://github.com/woocommerce/woocommerce/issues/29884

    Thread Starter squilib

    (@squilib)

    In https://github.com/woocommerce/woocommerce/issues/29884 Tamullen suggests to “Add the product as an additional Order item”, but I don’t have “Add item” under the total, I only have “Refund”. All my orders are no longer editable.

    My clients request exchanges or additions of dital items every day.
    This bug has a big impact on my business.

    I am confident that the bug will be fixed soon 🙂

    Thread Starter squilib

    (@squilib)

    I started this thread one month ago.
    I was waiting anxiously for the next version of Woocommerce, but the
    GRANT ACCESS permission bug has not been fixed.

    The Tamullen solution does not work (I don’t have “Add item” under the total, I only have “Refund”. All my orders are no longer editable.)

    I have many customers waiting for the grant access permission (I have to copy their orders from one platform to the new site) with dozens of digital files each.

    Plugin Support B C. a11n

    (@battouly)

    Hi @squilib,

    This bug has not yet been fixed that is correct and because this is a confirmed bug by the developers and marked high priority, I will go ahead mark this thread as solved based on the open bug.

    Please keep an eye on the open issue. You can also directly discuss any workaround under the same issue.

    Another option is to hire a developer to help you with custom codes.

    I can also recommend the following places for more development-oriented questions:

    WooCommerce Slack Community

    WooCommerce FB group

    Thanks!

    wpairwavz

    (@wpairwavz)

    @battouly
    Please consider this bug a Severity-1 issue.
    It is negatively impacting 100% of our customer base, and our revenue.

    The workaround to re-open the order impacts our shipping and fulfillment.

    Looking for this to be resolved ASAP.

    Many thanks.

    Sorry to see “Grant download permissions NOT working again” was not included in the latest WordPress update 5.5.0 – will this feature be re-enabled?

    Plugin Support gabrielfuentes

    (@gabrielfuentes)

    Hi @wpairwavz 👋

    Please create a new topic so that we can help you there!

    Cheers 🙂

    Please return the functionality as it was before version 5.3.
    My site is essentially useless unless I can update my customer accounts manually.
    I have no idea how to move forward other than to email files to my customers. This is super URGENT.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.