Support » Plugin: Events Manager » Grandchild pages/permalinks 404 error

  • Resolved Elliott Stocks

    (@elliott-stocks)


    Hi,

    I’ve noticed that when adding a grandchild page under a parent of /events/ the page is “not found” and returns a 404 error e.g.

    /events/an-event/event-info

    If I change the permalink slug “Events” from events to events/ (note the added /) this fixes the above error, but then breaks child pages of events e.g.

    /events/an-event this URL is now /events//an-event where as the above grandchild slug doesn’t have the double slash //

    Has anyone else noticed this problem or have any advice on how to solve it?

    I’ve disabled other plugins and the problem only occurs when events manager is enabled.

    Appreciate any advice,

    Thanks !

    http://wordpress.org/extend/plugins/events-manager/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Marcus

    (@netweblogic)

    due to the way permalinks work, we have to hard code rules for child pages of the events page, I haven’t done that for grandchild pages

    something we could look into in the future but I think your best option right now is to not use grandchild pages under the same slug as your events are shown.

    Thanks for your quick reply, this is on a clients website so I wanted to get it working. I took a look at the code and made some changes in /classes/em-permalinks.php about line 22

    You can view the changes on github

    After flushing the rewrite rules it seemed to work fine! If possible could you take a look at the code and let me know if that seems correct to you?

    Thanks :).

    Sorry I meant line 99 😉

    Plugin Author Marcus

    (@netweblogic)

    yup, that looks right to me. You may want to look into adding this outside the em plugin using hooks (like we do on that file)

    so it’s upgrade safe.

    Will do 🙂 You could always add it into the core and save me the trouble haha

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Grandchild pages/permalinks 404 error’ is closed to new replies.