Support » Plugins » GPLv3 Question

  • I just finished creating my first WordPress plugin. I included an options panel in it which is licensed under GNU version 3. Does this mean I am allowed to use it in a WordPress plugin? I want my plugin to be listed in the Plugin Directory, so it must follow the guidelines.

Viewing 1 replies (of 1 total)
  • Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    I included an options panel in it which is licensed under GNU version 3. Does this mean I am allowed to use it in a WordPress plugin?

    Yes it does.

    I want my plugin to be listed in the Plugin Directory, so it must follow the guidelines.

    That’s a good thing. 😉 Give these articles a read if you haven’t already.

    http://codex.wordpress.org/Writing_a_Plugin
    http://codex.wordpress.org/Plugin_Submission_and_Promotion

    I’m not a plugin reviewer (and that’s a good thing too, my PHP is awful) but the guidelines aren’t that difficult. If there is a problem with your plugin submission then I believe you’d get an email.

Viewing 1 replies (of 1 total)
  • The topic ‘GPLv3 Question’ is closed to new replies.