WordPress.org

Support

Support » Installation » Got thru steps but not login

Got thru steps but not login

  • I figured out how to get it all installed and after a couple of hurdles, I made it past all the steps then I was given the user “admin” and a password (which I wrote down and double checked). I entered it, then I was given a 403 error (forbidden). I hit the back button, but that didn’t get me anywhere helpful. I got impetuous and deleted all the WP files so I could re-upload, but then that didn’t clear the MySQL database. I don’t have priveledges to creat a new one, so I didn’t dare delete the only db there in the phpMyAdmin interface. Am I hosed for tonight? Will I have to wait until a.m. when web host’s tech support gets in and have them delete and set up a new DB?
    –utter newbie

Viewing 15 replies - 1 through 15 (of 15 total)
  • Mark (podz)

    @podz

    Support Maven

    You can put another install into the one database.
    Edit wp-config.php, and where it has a prefix of ‘wp_’ change that to something like ‘wp2_’

    Plus you can clear out all the tables WP has set up by using phpadmin and start again. No need to disturb the guys in tech support.

    thanks. I figured it out this morning. Last night, in phpadmin when i looked at the db, there was nothing at all listed. this a.m., the tech support guy must have changed something because when i looked (after i knew he was in) it did list all the tables wp set up in my db.
    thanks!

    tech support return to their pizza and colas.

    Well, I thought I had it, but I don’t. I did go through the process of importing my files from MT and that works. I can view the site and all that. However, I still can’t get in to log in and edit or make new posts. I have a feeling it’s just something that’s not working in my brain which is why I don’t get it 😉
    Why would I be getting a 403 error when I go to http://www.inthatnumber.com/wp-login.php? And why don’t I see a way to re-enter the PW/ID info?

    Looks like you’ve fixed it? I get the login screen from that URI.

    weird! i get:
    “You are not authorized to view this page”

    Um… I’d offer to log in and run your blog for you, but that doesn’t really seem to be a long-term solution. 🙂
    At this point, if it were me, I’d clear every cache I could find and reboot. It’s my way of waving a white chicken over my keyboard while chanting prayers in binary.

    I was thinking of looking in the cookies folder and dumping stuff from there. But, just to save my sanity: which is the WP file that contains the password and ID?

    It’s not in a file, it’s in one of the tables…
    wp_users (if you use the default prefix, otherwise it’s [your_prefix]users)
    field named ‘user_pass’. It’s encrypted. Somewhere on these forums is more details on just how it’s encrypted.

    I’ll have to look that up somehow. I’ve deleted tables and reinstalled WP twice now, and both times I get the same result: HTTP Error 403 – Forbidden
    It’s the weirdest thing. I wonder if it has to do with the server’s set up somehow?

    I don’t think it can be your server; I click on that link and go straight to your login page.
    Did you delete your cookies?

    My recollection of user/pass denials in WP is that I get a “user or password incorrect” kind of response rather than a generic 403 or 404.
    The password for ‘admin’ should not change until you change it yourself; is it possible you noted an “l” as a “1” or similar confusion?
    As I said above, somewhere around here are explicit descriptions of how the password is encrypted; I didn’t make a note of the page since, for how I work, it would be simpler to drop all tables and reinstall. But it concerns me that you’re getting a 403 rather than a ‘password error’, as this suggests the problem isn’t within, or entirely withing, your installation of WP.
    I’m really out of my depth here. If I had the sort of errors you describe, my approach would be pretty much scorched earth– delete everything, drop all tables, start again with a clean slate. It doesn’t exactly narrow down the true causes of catastrophic errors, but when there’s no data to protect, I’ve found it to be a faster route to where I’m going.

    I was having the same trouble — the question was answered in this thread:
    http://wordpress.org/support/index.php?action=vthread&forum=2&topic=7514&page=0
    You need to add index.php as a type of default page on your server, otherwise it doesn’t know to look for that page in the directory. You should be able to do this through your web host’s control panel or tech support.

    That was it exactly!!! Thank you so much for all your help. Very cool…now back to getting MT imported.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Got thru steps but not login’ is closed to new replies.