Support » Plugin: Anti-Malware Security and Brute-Force Firewall » Got stuck, got stuck (at 99%)

  • Resolved skywalker89

    (@skywalker89)


    Hi, somehow caught malware…

    your great plugin this time – for the first time – has issues getting through.. I am always getting stuck at 99% … it still seems to be running, but its on 99% for days now…

    Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (1) Got Stuck (2) Got Stuck (4) Got Stuck (8) Got Stuck (16) Got Stuck (32) Got Stuck (64) Got Stuck (128) Got Stuck (256) Got Stuck (512) Got Stuck (1024) Got Stuck (2048) Re-Checking Database for %<script%//frimeduble.com%</script>%

    the script still seems to change, so there seems to be progess..

    what can I do to get rid of it all?
    thx
    Dan

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Eli

    (@scheeeli)

    It looks like your scans are getting stuck on the DB Scan. To verify this you could un-check the Database Injections option under “What to look for”. and run the Complete Scan to see if it finishes.

    If your server is having issues only on the DB Scan then it is probably something to do with the settings or limitations on the DB server. Maybe it’s a low memory limit or a query time limit. How many records do you have in your wp_posts table?

    Thread Starter skywalker89

    (@skywalker89)

    HI Eli,
    sorry for the late replay, the scan took 6 days

    No issue when I deactivate the db injection scan

    when only running the db injection scan, I start to get the issues
    Got Stuck (1024) Got Stuck (2048) Re-Checking Database for %<a %viagra%

    I do not know how to check my db memory or query limit , will do some research
    also dont know how to check for records in wp_posts table

    If i find out, I will be back

    Thx
    Dan

    Plugin Author Eli

    (@scheeeli)

    6 days? that’s way too long!

    Just so you know it shouldn’t take more than an hour for the Complete Scan to finish, otherwise there is definitely something wrong with your server. The average site hosted on any of my own servers only takes around 10 to 20 minutes to finish the Complete Scan on the whole site. I’ve seen it take over an hour on some other server which are either under-powered or overburdened, but it should never take 6 days, that make the scan almost useless.

    You should talk to your hosting provider about all this. They should be able to tell you about your memory limits and database restrictions and help you access your database to find out how many records your tables have. You can also ask them about your error_log files so that you can find out what sort of errors are causing the site and the scan to take so long.

    If they are not helpful and cooperative (or maybe even if they are) you might want to thing about finding another place to host your site.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.