Support » Plugin: Active Directory Integration » Got no user and password – Where are the logs??

  • Windows Server 2008r2
    Apache 2.4
    WP 3.81

    When I tried installing this active directory plugin and configuring it, no matter what we do, I keep getting the same non-helpful result in the Test Tool output.

    AD Integration Logon Test
    openLDAP installed
    Got no user and password.
    Logon failed

    What does this even actually mean? Where are the logs to show me more about what’s going on behind the scenes? I went into the adLDAP.php file and discovered config variables for a higher level user to use for LDAP queries (which we need, because ours requires a logged in user), but that too did not change the result. That should be documented somewhere too – I never found any mention of those variables being in there to tweak.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Ok this is more troubling than I thought.

    I’ve spent a couple of hours looking over alot of code in this plugin. It seems that the error Got no user and password means the Test form is saying it thinks nothing was entered into the form fields.

    Of course I have entered content.. and I tried it in 2 different browsers in case it was something weird with one or the other. I added an Echo to see for myself what the $_POST[‘AD_Integration_test_user’] has for contents, click the Test button, and it shows an error in the window about it being an undefined index.. meaning the test form, or something else in the plugin, is not passing the test data along at all.

    I’m at a loss and very frustrated with the amount of time I’ve had to spend on this, and get no where.

    So it may be too late for the OP but for the rest of the internet that cares about this issue…

    We were able to resolve this as follows: because we are paranoid and wanted to make sure that if anyone inadvertently went to our wordpress instance over http they’d be redirected to https via mod_rewrite… The problem, though, is that when our default instance of WP was created, the admin used a wordpress address and base address of instead of so this module pulls that wp_plugin_url address of http, gets rewritten to https and leaves the post data behind.

    We only stumbled on this when I changed the method from post to get in the admin.php file and updated the corresponding vars in test.php to be _REQUEST instead of _POST…the way we have mod_rewrite configure the original URI request is rewritten which, when using a GET method, included the username and password in the string (I AM NOT CONDONING THAT…was just testing). The correct fix for us was to update the general settings of the wordpress urls to be https and it worked immediately.

    You could easily verify you have the same issue by verifying if the value of the url in your address bar is an https address but right click and view source of the page and see if it’s trying to submit the form to an http address.

    Hope this helps someone!


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Got no user and password – Where are the logs??’ is closed to new replies.