WordPress.org

Support

Support » Plugins and Hacks » ecSTATic » [Resolved] Got blocked (403) as admin

[Resolved] Got blocked (403) as admin

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author MikeSoja

    @mikesoja

    It’s likely you tripped the “Way Too Fast” blocking option, ie., too many accesses over a short period of time. See the last set of options on the Options page and up the “WTF sample” size to 10, or more. If you were blocked that way, a wait of 15 minutes would have left you unblocked.

    I’ve repeatedly locked myself out the same way.

    I’ll try to add a “Don’t block Admins” option, or just hard code it.

    that would be great if you could add this – or – could you post the code I would need to hardcode the plugin to add an option to “not block admins”

    I know I can increase the sample size but it would be cooler if as admin, I would be exempt.

    Thanks,
    Bob

    Plugin Author MikeSoja

    @mikesoja

    If you want to do it, yourself…

    In the file – ecstatic.php – in the function ecstatic_new_hit() which begins around like 540 or so (I’ve modified some of the functions since last release), the last “if” statement…

    Change it from…

    if ($ecstatic->score > 9) {

    To…

    if ($ecstatic->score > 9 AND !(current_user_can(‘administrator’))) {

    No admins will ever be blocked.

    I’ll probably leave it that way in the next release.

    Thanks for the idea!

    Plugin Author MikeSoja

    @mikesoja

    Oops. “like 540” == “line 540”

    So far so good Mike. Thanks,
    Bob

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Got blocked (403) as admin’ is closed to new replies.
Skip to toolbar