Support » Plugin: Advanced Browser Check » Got a lot ob problems with new version 3.0.1

  • Warning: require(WP_PLUGIN_DIR/advanced-browser-check/browscap/browscap.php): failed to open stream: No such file or directory in /…/wp-content/plugins/advanced-browser-check/abc-core.php on line 4

    Fatal error: require(): Failed opening required ‘WP_PLUGIN_DIR/advanced-browser-check/browscap/browscap.php’ (include_path=’.:/usr/share/php:..’) in /…/wp-content/plugins/advanced-browser-check/abc-core.php on line 4

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Mattias



    For some reason the WP_PLUGIN_DIR constant is not working correctly for you, if it did you should see a path and not the constants name in that error message.

    Do you see the error message on the frontpage (theme) or in you wp-admin area?

    Think I found the problem. Using Caching-Tools and cleared all the caches. Seems working now – I will check this a time…

    New problem – how many memory does this plugin need?

    Fatal error: Allowed memory size of 167772160 bytes exhausted (tried to allocate 72 bytes) in /…/wp-content/plugins/advanced-browser-check/browscap/browscap.php on line 718

    Plugin Author Mattias


    Hmm, I have not specific limit or amount of memory it needs. The only info I can give you is that I have 256MB set in my local dev php.ini, and that is at least enough.

    And I have not issues on my web hosting server, what the limit is there I do not know atm.

    I recommend you contact you hosting provider and ask them to help you bump up the memory limit in your php.ini file. OR, try any of the ways here

    Problem maybe fixed now. I have an onlineshop with a few hundert people every day. It’s impossible to give 256MB RAM to each connection, even I have 16 GB to use.

    The main problem was to have no write-access cache-folder in wp-content. I changed this reload and the memory error pops up. Check the folder a saw a hugh file browscap.ini. Update to 192MB Ram didn’t change the problem.

    Deleted this file any copied the two files from an other blog into the folder /wp-admin/cache. And reload – no problem anymore. Reduced memory from 192MB to 100MB standard – still no problem. Seems working now and the two files in cache are very small. Will wait and check again – never have such problems with versions before 3.0.

    Maybe this helps.

    Plugin Author Mattias


    The browscap.ini file and the cache cache.php files are new in version 3.0.0 and the reason you never seen them before.

    The first time the plugin is executed, it downloads the browscap.ini file and create the cache.php from that file.

    My guess is that when trying to create the cache.php file from the .ini file, the script run out of memory.
    Now when you manually created the cache.php file the script don’t have to work so hard again and you don’t see any memory errors.

    I’m sorry to say but I can’t use the new version. Customer told us today that the site isn’t working correctly. The problem is your caching when a blog is still using a cache.

    We must have to use quickcache because of our woocommerce-shop to speed it up and you cache seems to have problems with this situation. We are going back to the old version – all is working fine again.

    Maybe you have an option to use your plugin without caching?

    Plugin Author Mattias


    I’m sorry to hear that.

    I have not tested the plugin with the quickcache plugin, there might be a conflict there.

    I have tested it with W3 Total Cache and have the plugin running on multiple sites using my plugin with W3TC.

    Do you by any chance have any more detailed information about the issues your customers have? Would be great to have and see if it might be something that I can solve.

    For the cache folder. Unfortunately the Browscap.php library requires a cache folder to work properly. I don’t like it 100% myself but it is the best solution at this moment.

    Plugin Author Mattias



    I have just released a new version of the plugin that should solve the memory issues.
    Please let me know if you still have issues or not.


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Got a lot ob problems with new version 3.0.1’ is closed to new replies.