Support » Fixing WordPress » GoogleSpell error:443

  • jasoj2


    The following error occurs when attempting to check spelling when writing a new post:

    Error response:
    <b>Warning</b>: fsockopen() [function.fsockopen]: unable to connect to ssl:// (Unable to find the socket transport "ssl" – did you forget to enable it when you configured PHP?) in <b>C:\xampp\htdocs\wordpress\wp-includes\js\tinymce\plugins\spellchecker\classes\GoogleSpell.php</b> on line <b>85</b>
    Could not open SSL connection to google.{“id”:null,”result”:[],”error”:null}

    I have seen this error listed several times on the forums and have seen varied responses, but no definitive means of correcting the problem.

    I use XAMPP and run my WordPress blog from a home server. However, I am primarily a hardware guy, not a software guy, so much of this coding stuff is Greek to me. That said, does anybody know how I can fix this issue? I am set to have a large number of people use the blog for academic purposes, and the spell checking is rather important. This is the only error message that has presented itself in two weeks of testing. Please provide a detailed response, or a link to a detailed explanation.

    For example, if I am to “configure” SSL properly (if it somehow is not configured already), either explain how this is done or provide a link, if possible. I have checked the php.ini and the GoogleSpell.php files, and everything seems to be in order. Google searches and searches of these forums seem to yield no information.

Viewing 3 replies - 1 through 3 (of 3 total)
  • nmace


    Was this ever figured out? I’m getting this same error when I go to cpanel and look at error logs, it pops up, about once per day…

    This normally means PHP was not configured with CURL and/or openSSL. I had the same problem but I had PHP configured with CURL and openSSL. This fixed it:

    edit rpc.php which is in wp-includes/js/tinymce/plugins/spellcheck and comment the line that says header('Content-Encoding: UTF-8');. that should do the trick

    You need to enable the CURL library in PHP.

    On Windows:

    1. Uncomment (or add) the following line to the “Dynamic Extensions” section of your php.ini file:
    2. Make sure the following files can be found from your PATH system variable (I copy them to C:\windows\system32\):


    Hope that helps. ; )

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘GoogleSpell error:443’ is closed to new replies.