Support » Plugin: SiteGround Migrator » Google’s Site Kit causes Critical Environment Error

  • Resolved thegr8one

    (@thegr8one)


    First check the wp-content/siteground-migrator.log for the issue.
    Secondly if the reason for the critical error is caused by Googles Site Kit Plugin (probably since 1.2.0.) delete the plugin first.

    Example from the log: [message] => Uncaught PharException: tar-based phar “/[…]/public_html/wp-content/uploads/[…]/plugins/google-site-kit.tar” cannot be created, filename “dist/assets/js/chunk-googlesitekit-adminbar~chunk-googlesitekit-setup-wizard~chunk-googlesitekit-setup-wizard-proxy[…].js” is too long for tar file format in /[…]/public_html/wp-content/plugins/siteground-migrator/includes/class-siteground-migrator-files-service.php:205

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    I am afraid that there isn’t much we can do about it since that’s your current host not being able to zip such a big folder which to be honest isn’t very big having in mind the total size of Google Site Kit plugin.

    VP

    (@studio500)

    This also happens with sitegrounds own hosting when trying to move a wordpress installation from one siteground hosted site to another.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.