Support » Plugin: GN Publisher: Google News Compatible RSS Feeds » GooglePublisher Not Fetching My Feed

  • Hello there. It seems I’m having the same issue as many others here, in that Google Publisher Center won’t fetch my feed, and for hours still displays

    There are no articles in this section.

    I have tried the following feeds, but all have the same result:

    https://www.WhyGames.co.uk/feed
    https://www.WhyGames.co.uk/feed/gn
    https://www.whygames.co.uk/category/news/feed/gn

    Nothing appears to be fetched.

    I validated the html and it’s valid and I tested the feed on a free iOS RSS reader, and it displays the feed.

    But still nothing on Google’s side.

    I reached out to GoDaddy Hosting and asked them to allowlist/unblock the “Feedfetcher-Google” but they have no idea what I’m talking about.
    I spoke to 3 different people and insist everything is fine.

    I’m not sure how to proceed.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter whygames

    (@whygames)

    I finally reached a GoDaddy advisor who knew what I was talking about, but they said this:

    Thank you for staying connected. I am really sorry for the inconvenience caused to you. By default, the crawler will be enabled only and we did not disable it. The cPanel page that you are able to see is the same one we are seeing from our end.

    So I have no idea why Google won’t fetch.
    Any advice would be greatly appreciated. Thank yo in advance for your time.

    Plugin Author Chris Andrews

    (@christopheran)

    Hi WhyGames,

    You’re right, Google’s FeedFetcher is not crawling/fetching the feeds. Not even once.

    If you could double-check something for me, if you go to your Publisher Center, then your publication, and in the sections, make sure they are set to ‘feed’ and that you are using a feed url that ends in /gn, save if you have made any changes (it’s easy to overlook the save button there), and then hit the ‘refresh’ link.

    That should almost immediately fetch the feed. Wait 10 minutes or so, then refresh the entire page and see if that loads the articles.

    If it doesn’t load the articles… hmmm… let me know and I’ll think about this some more and see what I can come up with.

    Question – since installing and activating GN Publisher, have you published any new posts?

    I’m going to be on the road today, please forgive any delays in my responses,

    Chris

    Thread Starter whygames

    (@whygames)

    @christopheran Thank you for your response. I appreciate your time.

    To make sure I followed your instructions accurately, I deleted all sections and started again using the following link:

    https://www.whygames.co.uk/feed/gn

    (you can see a screenshot here).

    I’ve waited 20 minutes and refreshed, and still doesn’t appear to be fetching.

    RE your question, I’ve had GN Publisher installed for about 3 weeks (since the beginning of the site) and published 12 Posts since.

    Thank you again.

    Plugin Author Chris Andrews

    (@christopheran)

    Okay… hmmm…

    I’m not sure what’s going on. There does seem to be an issue on Google’s end right now, but your issue is a little bit different.

    In those other cases, the feed is being crawled and the articles are added to the Publisher Center, but don’t appear on the front end of the Publication in Google News.

    In your case, Google is not crawling the feed, and isn’t receiving the ping when new articles are published.

    I’m going to try pinging Google to crawl https://www.whygames.co.uk/feed/gn to see if that triggers any changes or errors, let me know if you see any changes on your end,

    Chris

    Plugin Author Chris Andrews

    (@christopheran)

    Both that and https://www.whygames.co.uk/category/news/feed/gn pinged okay and were crawled by Google.

    They should show up with articles being included in your sections in the Publisher Center.

    I suspect this is (another) issue on Google’s end. If your Publication isn’t live yet, it won’t update regularly until it is approved – so expect delays there. It *should* have updated when you first added the urls and when you hit the ‘refresh’ link, but…

    If it isn’t live and you are about to submit it for approval, I would recommend only having one or two sections. There’s less that can go wrong. Once it’s approved, you can add additional sections and you don’t have to go through the approval process anymore.

    Let me know if those have loaded up okay now,

    Chris

    • This reply was modified 2 months, 2 weeks ago by Chris Andrews.
    Thread Starter whygames

    (@whygames)

    @christopheran Hello again. Sorry for the delay (timezones).

    I’ve just checked and it still hasn’t updated from yesterday.
    No articles are showing and it still says:

    There are no articles in this section

    It’s very strange.
    I’m not sure what more I can do.

    Is there anything I should be doing on WordPresses side?
    Thanks again for your time. I really appreciate it.

    Plugin Author Chris Andrews

    (@christopheran)

    No, I think you’ve done everything you can.

    I think this is probably the same issue other publishers have reported. We (the Google News Product Experts) have been keeping Google up to date on the number of publishers reporting this problem.

    I would recommend contacting Google News Publisher Support and letting them know that your site is affected by the ‘no articles in this section’ issue. You can contact them at:

    https://support.google.com/news/publisher-center/contact/news_default

    They have not been offering any effective solutions at this point, but they are documenting affected sites from what I’ve been told,

    Chris

    Thread Starter whygames

    (@whygames)

    @christopheran
    It seems we finally have success.

    Google News team replied to me, and basically confirmed they knew of the issues and it was just a case of waiting for the algorithm to fetch the data.

    They mentioned the more sections you add, or change, or delete and re-add, it can make wait times longer.
    So if anyone’s reading this with the same issue, leave your most recent section, and just wait.

    It took 3 days, but my Articles finally refreshed, and are now showing in the News preview and I could submit for approval. Let’s just hope they go live easily once approved.

    Thanks again for your help Chris, and for developing the plugin.
    I appreciate your time.

    Plugin Author Chris Andrews

    (@christopheran)

    Great! Thanks for letting me know,

    Chris

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.