WordPress.org

Support

Support » How-To and Troubleshooting » Googlebot blocked from home page

Googlebot blocked from home page

  • Hello – I’d be very grateful if anyone could help with this problem!

    URL: http://www.richardfordphotography.co.uk (Domain with 1and1)
    Host: 1and1

    When I test crawler access in Google Webmasters control panel, the result shows “blocked by line 2; disallow/detected as a directory; specific files may have different restrictions.

    The same test result for the robots text is shown as
    User-agent: *
    Disallow:/ (ie BLOCK all search engines)

    If I put in the address bar http://www.richardfordphotography.co.uk/robots.txt
    I get
    User-agent: *
    Disallow: (ie ALLOW all search engines)

    I have enabled google sitemap in 1and1 control panel
    Webmaster reports “valid sitemap reference detected”
    I have enabled my wordpress privacy setting to ‘public’

    I did have WP plugins all in one SEO and xml sitemaps activated, but I turned them off to try an isolate my problem

    I’m tearing my hair out trying to work out why googlebot is blocked from my home page! 1and1 have said everything is ok their end.

    Thank you for any suggestions

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Googlebot blocked from home page’ is closed to new replies.
Skip to toolbar