Support » Plugins and Hacks » Google XML Sitemaps problems

  • I’ve been struggling with this for several days now, and after combing the forums and google, I’m stumped. I’ll lead with saying I have almost no experience with coding, php, xml, etc, and I’m a total newbie at wordpress, so these may be easily resolved questions and I just can’t figure them out.

    I downloaded the Google XML sitemaps plugin, and uploaded, unzipped, and activated it according to the directions. I then tried to build the sitemap, but got this error:

    # There was a problem writing your sitemap file. Make sure the file exists and is writable. Learn more
    # There was a problem writing your zipped sitemap file. Make sure the file exists and is writable. Learn more

    After researching through the forums, I reset the permissions on those files. I have tried them in the public_html, wp-contents/plugins , wp-contents, all to no avail.

    So after reading through the forums again, I debugged and got an error:
    fopen(/home/ramblera/public_html/sitemap.xml) [function.fopen]: failed to open stream: Is a directory in /home/ramblera/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 1737″ That lead me to change the custom location to match that error. When i did that, the error disappeared when i debugged again. I was left with this note:
    Please edit in wp-includes and set SAVEQUERIES to true if
    you want to see the queries.

    I have a wp-db.php, but no that I can find.

    I have also tried to build manually, but it continues to give me the original error about the sitemap files.

    I’ve tried deactivating the plugin, I’ve tried removing it and re uploading, I’ve tried every fix I can see in the forums that seems to apply to this situation. I know I’m probably doing something very simple wrong, but I don’t have any idea what it would be. I’m going a little crazy here and have no idea how to fix my problem! Any help would be greatly appreciated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Oh, I should probably add that I’m using Pressrow as my main theme. I’m totally stumped.



    Volunteer Moderator

    Here’s the extensive FAQ of the plugin page with this link to the Sitemap Files Not Being Written to start off. Scroll up and down page for other FAQ’s etc.

    I’ve already read that FAQ about 5 times, and tried every single suggestion there multiple times, as well as reading all the support pages I can find here and through the forums. I’m really looking for some specific help for the errors that I’m getting.



    Volunteer Moderator

    Ok, in your first post, you’d tried to move the sitemaps this and there. Just to clarify some matters, say WP is in root of server at
    1. upload plugin folder (take note that when you unzip the plugin, it may be inside another folder, you have to upload only the root folder that contains the files) to
    2. create two files in root of WP install and CHMOD to 666

    3. depending on server, you might need to CHMOD 777 your root folder for the first time you build the sitemap in Settings > XML-Sitemap Right after first build, you CHMOD root folder back to 755
    Good luck.

    I’ve done all that, but just to be sure, I tried again. It still brings up all the same errors.

    I think I may just have to scrap this since I’m obviously missing something.



    GDWinters, email me at dbell @ tdbell enterprisesdotcom, (no spaces, and replace the word dot with a .) I’ll walk you through fixing it.


    What verison of WordPress, PHP and MySQL do you have installed. I have installed Google site maps many timesand have hadno problems. Try uploafing a file to your root directory with the name sitemap.xml and see if you can read it…

    I have this same problem now, did you ever get it fixed?

    Does anyone have any solutions for this? I’m reading around and it looks like this problem crops up when WordPress is installed in a subfolder (not in the root of the site).

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Google XML Sitemaps problems’ is closed to new replies.