Support » Plugins and Hacks » [Resolved] Google XML Sitemaps and WordPress 2.5.1

[Resolved] Google XML Sitemaps and WordPress 2.5.1

  • It seems there are issues with Google XML Sitemaps and WordPress 2.5.1. Before, it was working great, but now, it won’t let me publish / edit / delete any post, giving me a timeout error.

    I went “the old way” to figure out the culprit of this problem (IE: deactivating all plugins, and activating them all one by one, each time writing / deleting a post).

    It was when I activated XML Sitemaps, that it stopped working…

Viewing 15 replies - 1 through 15 (of 32 total)
  • I’m not having this problem

    On the configuration page, it seems it never finishes rebuilding the database after each new post. I gave it an unlimited timeout, more memory, and took about 200 seconds to do it, something that, with 2.5, never happened

    Works for me as well.

    I am having the same problem. When i don´t get a timeout it take about 50 to 60 seconds to publish a post. And i had an error that the “last” sitemap couldn´t be build etc ….
    Would be great if this would be fixed.

    WP 2.5.1 & about 2100 posts on the blog.

    Deactivated “Page Links To”, which, according to the debug, seemed to be causing trouble with Google XML Sitemaps. But to no avail, since it still takes about 300 seconds to compile a sitemap…

    It is true, i test it, same problem here =/

    Okay, why would the plugin work for me and not for others? The debug information comes through with no errors, I can rebuild the sitemap successfully (actually turn around time to page refresh was about 12 seconds):

    The building process took about 2.76 seconds to complete and used 20.25 MB of memory.

    I ran a test post to try and duplicate the problem and from time I hit the “Publish” button to the actual moment the post was published was Approximately 11 seconds. The sitemap rebuilt normally at time of publish:

    The building process took about 6.37 seconds to complete and used 20.25 MB of memory.

    One of the things I did quite awhile ago was to stick a “php.ini” file (normally found in your root directory…I made a copy of mine) into my “plugins” folder where I was concerned about script functions that took more than the default 8 or 16 MB’s of memory to execute. Also, after a major upgrade, it’s not uncommon for certain scripts which ran fine before to require more memory to execute the first few times. I don’t know why this is exactly but I’ve encountered it more than once.

    Here’s a couple things you can try:

    1. in the Google XML plugins settings, set memory limit to 32 and save your settings. Then try rebuilding again. If successful then try another post and see what happens.


    2. In any WordPress install, your host should have put a “php.ini” file in your root directory. Bring this file up in your favorite editor and look for a section called “Memory Resources” or the equivalent. It should have a couple of lines that look like this:

    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    memory_limit = 32 ; Maximum amount of memory a script may consume (8MB)

    If memory limit isn’t equal to 32 (it might be set to 16 for example) then change the number to 32. You might also want to make sure that the “max_execution_time is set to a minimum of 30 also. Once that’s done, save it back to your root directory on your server. Now try to rebuild your sitemap.

    If you encounter the same problem then make a copy of that “php.ini” file and drop it right into your “wp-content/plugins” directory and try rebuilding once more. I’d be surprised if one of these solutions didn’t solve your problem.


    well … that maybe a solution but it still didn´t work well. i have a memory limit of 50 and a max_execution_time of 90sec.

    but it still take about 40 to 50 seconds to build the sitemap. i get a lot of notices when i run the plugin in debug mode: Notice: Undefined property: stdClass::$args in /wp-includes/taxonomy.php on line 1068.

    god i wish someone could post a soultion for this 🙁 50 seconds after publishing a post is way too long ….

    While the plugin is working for me i still have the same notice : Notice: Undefined property: stdClass::$args in /wp-includes/taxonomy.php on line 1068 but i believe that hasn’t to do with the plugin.

    Hi all,

    thanks for the feedback! There was a change in the WordPress 2.5 caching system which resulted in a database query for every post when the sitemap was created. Because of this, it is likely that the script run into the memory or time limit.

    I’ve added a workaround in the new release which fixes this issue. You can get it here:


    I’m also working on the new major version of the plugin which is split into several files, so only the PHP code which is needed for the current request is loaded. That means that only a very small “code loader” is active on every page load and the sitemap generator itself is just loaded when you really want to rebuild the sitemap.

    You can help me by testing the new test release (also known as “development version”). Note that this version might not work completly, but it would be great if you help me and report what’s not working 🙂

    The current development version is always here:

    Please note that if you update to this version, the plugin should be automatically disabled afterwards since the filename of the core plugin file changed. You’ll need to activate it again at the plugin page.

    Thanks and best regards,


    I tried both development and last version ( in WP 2.5.1 but it told me “permission denied” when i tried to access to configuration page. I have role manager but google xml sitemap doen’t appear there. does it happen only to me? I also tried to reinstall but it happens the same.

    Hi arnee,

    thx for the upgrade. I installed it and it worked good.
    before the upgrade:

    time to create sitemap: 50 sec
    after: 14 seconds

    memory before 18 mb
    memory after 17 mb

    THATS much better 🙂

    Hi Arne,

    I’ve also been having a problem. Strangely I have 2 blogs running 2.5.1 and one has no problems with the plugin but the otehr just refuses to play nicely.

    I have tried both the development version and the version but still nothing but a blank screen.

    One thing I notice is that if I remove the plugin from the server and then re-install it, it shows the data from the previous attempt, almost as if it’s kept it in some sort of cache, I’m wondering if this is causing the problem with the newer versions?

    Any help would be appreciated 🙂

    You probably need to change permissions of the plugin folder (755).

    Thanks for the update, it’s working great now :).

    Hi, thanks for the answer but i checked plugin folder permissions and they are correctly set. Any idea?

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘[Resolved] Google XML Sitemaps and WordPress 2.5.1’ is closed to new replies.