Support » Plugin: Easy HTTPS Redirection » Google won’t index page with this plugin

  • Resolved PeterKirk

    (@peterkirk)


    When this plugin was activated, my page (accessed using HTTPS) was not showing up in Google searches. I investigated with Google Search Console. This reported the visitor view of the page as correct but the Googlebot could only see a redirect page, which was doing a 301 redirect of the page to itself. This seems to have been generated by the .htaccess edited by the plugin. For this reason Google was refusing to index the page.

    I removed the edits to .htaccess and disabled the plugin. Now the Googlebot sees the page correctly and has indexed it – but I have no HTTPS redirection.

    The problem seems to be that the plugin is redirecting not just the HTTP version of the page but also the HTTPS version, which causes an incorrect recursive redirect. That is no doubt why some people here have reported recursive redirect errors on pages, although for some reason users didn’t see that problem on my page.

    Is there any way I can work round this issue? Do I need to find another HTTPS redirection plugin?

    Did this happen only to me, or have other people noticed that this plugin destroys their SEO efforts, in a way which Yoast SEO doesn’t see?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    When this plugin was activated, my page (accessed using HTTPS) was not showing up in Google searches.

    Did you configure your SSL certificate correctly?

    I removed the edits to .htaccess and disabled the plugin. Now the Googlebot sees the page correctly and has indexed it – but I have no HTTPS redirection.

    Are you saying that when the plugin is disabled your site works correctly or not?

    Is there any way I can work round this issue? Do I need to find another HTTPS redirection plugin?

    The issue might be unique to your site settings.

    I removed the edits to .htaccess and disabled the plugin. Now the Googlebot sees the page correctly and has indexed it – but I have no HTTPS redirection.

    Do you have another plugin that might be causing this issue?

    Did this happen only to me, or have other people noticed that this plugin destroys their SEO efforts, in a way which Yoast SEO doesn’t see?

    If this plugin destroyed the SEO, there would not be more than 100,000 current installs. I think this might be a conflict with a particular configuration setting in your site and Yoast SEO settings. Do you have the latest version of Yoast SEO plugin? What type of server is your site hosted in?

    Kind regards

    • This reply was modified 7 months, 4 weeks ago by  mbrsolution.

    Thank you for your reply.

    It seems that the issue was only with my pages, not my posts. This may be why other users have not noticed it.

    I believe my SSL certificate is properly configured. It has been working correctly for over a year.

    Without your plugin, my site seems to work properly, but without HTTP to HTTPS redirection. This is not a big problem but may have a negative effect on my SEO.

    I have the latest version of Yoast SEO. I don’t know of any other plugins that might be causing this issue. I don’t want to experiment too much as this is a live business site.

    I have been playing around with this a bit. Without the plugin activated, I added the following to the top of my .htaccess:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>

    This code broke the Google fetch, which shows a recursive redirect for my HTTPS page. The Google fetch results, listed as “Downloaded HTTP response”, start with a line “HTTP/1.1 200 OK” and end with “The document has moved here” with link to its own URL.

    I am wondering if somehow HTTPS is being redirected to HTTP, and then back. Anyway it doesn’t look as if the issue is with your plugin, so I’m sorry for suggesting that.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    I am wondering if somehow HTTPS is being redirected to HTTP, and then back. Anyway it doesn’t look as if the issue is with your plugin, so I’m sorry for suggesting that.

    No problem 😉 Let us know if you find a solution to your issue. And perhaps share you solution here for others to see.

    I am marking this thread as resolved since the issue is not related to our plugin.

    Kind regards

    • This reply was modified 7 months, 4 weeks ago by  mbrsolution.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Google won’t index page with this plugin’ is closed to new replies.