WordPress.org

Forums

WordPress SEO by Yoast
Google WMT rejects sitemap_index.xml (30 posts)

  1. dgeene
    Member
    Posted 1 year ago #

    When I want to setup the Sitemap details in Google WMT, Google comes with an error.
    See picture in link below (in Dutch)
    Link picture

    The errormessage is: Uw sitemap lijkt een HTML-pagina te zijn. Gebruik in plaats daarvan een ondersteunde sitemapindeling.

    In English: Your Sitemap appears to be an HTML page. Instead, use a supported sitemap format.

    What to do?

    http://wordpress.org/plugins/wordpress-seo/

  2. Jack
    Member
    Posted 1 year ago #

    I have this same problem.
    When I click on the button Sitemap in the option page, it opens up the homepage instead of a sitemap. Also I can't find it on the server.

  3. mikeotgaar
    Member
    Posted 1 year ago #

    Could you guys please include links to your sites so testers can take a look.

    @dgeene
    Sounds like an XML encoding issue as the sitemap is being found. Most common reason is extra blank lines being added at the top of the sitemap.

    @Jack
    It's a different issue. You won't find the sitemap as a file on the server - the plugin creates a virtual file, not a physical one.
    Something is re-directing the lookup request to your homepage - Maybe you have a 404 plugin to redirect broken links this way?

  4. dgeene
    Member
    Posted 1 year ago #

  5. Jack
    Member
    Posted 1 year ago #

    @mikeotgaar I have no 404 plugin active.

    This is the site: http://www.halal-slaughter-watch.org/

    I'm using Genesis and WPML.

  6. picks44
    Member
    Posted 1 year ago #

    Same problem for me, http://www.rodcraft.com/sitemap_index.xml shows the homepage...

    My plugins list :

    • Always Edit in HTML
    • BackUpWordPress
    • FancyBox for WordPress
    • Google Analytics for WordPress
    • Installer
    • Meta Slider
    • Remove Widget Titles
    • ShareThis
    • Widget Logic
    • WordPress SEO
    • WPML Media
    • WPML Multilingual CMS
    • WPML String Translation
    • WP Smush.it

    Please help ! :)

  7. Jack
    Member
    Posted 1 year ago #

    Ok, I'm also listing my active plugins, just to be sure ;)

    Anti-Captcha
    Background Manager
    BackWPup
    Category Checklist Tree
    Cool Video Gallery
    Custom Recent Posts Widget
    FancyBox for WordPress
    Genesis Featured Grid
    Genesis Featured Images
    Genesis Featured Widget Amplified
    Genesis Grid
    Genesis Simple Breadcrumbs
    Genesis Simple Edits
    Hotfix
    Image Widget
    Page-list
    Regenerate Thumbnails
    SEO Data Transporter
    Shortcodes Ultimate
    Simple Page Ordering
    Simple Social Icons
    Spots
    Video Sidebar Widgets
    Widget CSS Classes
    Widget Logic
    WordPress SEO
    WPML CMS Nav
    WPML Media
    WPML Multilingual CMS
    WPML String Translation
    WPML Translation Analytics
    WPML Translation Management
    WP No Category Base - WPML compatible
    WP Robots Txt
    WP Show IDs

  8. mikeotgaar
    Member
    Posted 1 year ago #

    @dgeene

    At the moment there's a site map generated by the "Google Sitemap Generator Plugin" /sitemap.xml

    The /sitemap_index.xml link returns a 404 error

    This is a physical file - Yoast's plugin has problems if it exists - The Google Sitemap Plugin doesn't delete the file when uninstalling/deactivating

  9. mikeotgaar
    Member
    Posted 1 year ago #

    @picks44 @Jack

    Looks like you're both using the WordPress Multilingual Plugin (WPML)
    /wp-content/plugins/sitepress-multilingual-cms/

    There's a known bug mentioned here http://wpml.org/forums/topic/yoast-wordpress-seo-sitemap-xsl-error/

    Also maybe worth checking some of the other topics http://wpml.org/forums/topic-tag/yoast/

    With v1.4.19 onwards, Yoast made a lot of code changes inline with latest WordPress best practices.

    Sorry I can't test the fix from the forum - commercial plugin

  10. Jack
    Member
    Posted 1 year ago #

    Now I'm getting redirected to my homepage, each time I hit the sitemap button. Damn, this plugin always gives me headaches :( so that it makes me wonder why it ever became so popular.

  11. picks44
    Member
    Posted 1 year ago #

    The solution here http://wpml.org/forums/topic/yoast-wordpress-seo-sitemap-xsl-error/ doesn't fix anything for me so far... :(

  12. Jack
    Member
    Posted 1 year ago #

    For me neither...

    I also tried adding the code on this page http://yoast.com/wordpress/seo/faq/ to my htaccess file, before the WP rewrite rules, as Yoast pointed out. That only gives me a 500 internal server error and making my site unreachable.

  13. mikeotgaar
    Member
    Posted 1 year ago #

    Sorry you guys are still battling with this...
    The .htaccess code mod definitely won't work for this problem.

    I'm looking at another option (nice you guys are willing to experiment) - will post shortly

    By the way - anyone tried reverting to an older version of WP SEO - http://downloads.wordpress.org/plugin/wordpress-seo.1.4.18.zip">v 1.4.18?

  14. picks44
    Member
    Posted 1 year ago #

    It's nice of you to help us :)
    How do I revert the plugin ? Erase the current folder et replace with this one will do the trick ?

  15. Jack
    Member
    Posted 1 year ago #

    Just replaced all the files with the older version and guess what? It works! I get a sitemap with seperate files for each language.

    Thanks Mike!!! :)

    Nevertheless and perhaps I should be really gratefull ... ;) I do regret that I have to use this plugin instead of the simple Google XML Sitemap plugin I always use together with the equally simple SEO of the Genesis Framework.

    But for now I'm happy. Hope it works for you too Picks44!

  16. mikeotgaar
    Member
    Posted 1 year ago #

    If you're willing, try this (also untested) mod to WP SEO, to replace the deprecated code removed in v 1.4.19.

    Insert the following the following after line 62 in wp-seo.php

    $pluginurl = plugin_dir_url( __FILE__ );
    if ( strpos( $pluginurl, 'https' ) === 0 && strpos( get_bloginfo( 'url' ), 'https' ) !== 0 )
    	$pluginurl = substr_replace( $pluginurl, 'http', 0, 5 );
    define( 'WPSEO_FRONT_URL', $pluginurl );
    unset( $pluginurl );

    I've published a more comprehensive discussion with fuller guidelines here
    http://tech.graphicline.co.za/wordpress-seo-sitemap-shows-home-page/#fix2

  17. Jack
    Member
    Posted 1 year ago #

    You mean after the following line?

    define( 'WPSEO_VERSION', '1.4.18' );

    The exact same code you posted is already there (???).

  18. Jack
    Member
    Posted 1 year ago #

    I just read that part on your site. It see that it should have been placed in the newer version... :(

    I will try that in a second...

  19. Jack
    Member
    Posted 1 year ago #

    Nope, doesn't work in the wp-seo.php file of 1.4.21. Getting the homepage again. Reverted quickly back to 1.4.18 :)

  20. picks44
    Member
    Posted 1 year ago #

    I reverted to 1.4.18 also, it's working, but XML files for other languages don't work... see http://www.rodcraft.com/sitemap_index.xml.

  21. Jack
    Member
    Posted 1 year ago #

    That's strange. Looks like you're having the same setup as I have. Perhaps change some settings? Also I noticed that deactivating, saving, activing and saving again worked for me. (active sitemap)

    Under permalinks I have nohting checked.
    Under Sitemaps I did not check Disable author/user sitemap, although I have no idea if that makes sense.

  22. mikeotgaar
    Member
    Posted 1 year ago #

    @picks44
    See the link I posted above - there's some info about reverting the plugin, and some other tips.

  23. mikeotgaar
    Member
    Posted 1 year ago #

    @Jack
    Thanks for the feedback on my suggested mod to the newer plugin. It's hard to find solutions without being able to test...

    Glad though that reverting worked for you. I'd say stick with 1.4.18 until one of the plugin devs fixes the incompatibility.
    (I sometimes install Plugin Update Hider plugin on client sites when we are forced to use older plugin versions to keep critical functions - stops other admins updating the faulty plugin)

    Fully agree with you about Google XML Sitemap plugin - prefer to use it as well.

    Give me a moment - I saw something about the problem with the alternate language yesterday - stylesheet error - need to find it again

  24. mikeotgaar
    Member
    Posted 1 year ago #

    Some possible solutions to 2nd language problem

    http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-www-error-805303f4

    There's also an .htaccess fix that MAY work IF you have an .htaccess security file in the wp-content folder by changing Deny from all rule to:

    Order Allow,Deny
    Deny from all

    <Files "xml-sitemap-xsl.php">
    Allow from all
    </Files>

  25. picks44
    Member
    Posted 1 year ago #

    Removing the XML stylesheet worked.

    /**
    	* Filters XML sitemap stylesheet
    	*/
    	function set_stylesheet(){
    		global $sitepress_settings;
    
    		if(@$sitepress_settings['language_domains'][$this->get_sitemap_language()]){
    			$language_domain = $sitepress_settings['language_domains'][$this->get_sitemap_language()];
    			$wpseo_dirname = str_replace('wp-seo.php', '', WPSEO_BASENAME);
    			//$wpseo_domain_path = $language_domain . '/wp-content/plugins/' . $wpseo_dirname;/*$this->stylesheet = '';*/
    			$this->stylesheet = '';
    		} else {
    			$this->stylesheet = '';
    		}
    		return $this->stylesheet;
    	}
  26. Jack
    Member
    Posted 1 year ago #

    Did you remove all that from the .18 or the .21 version?

  27. picks44
    Member
    Posted 1 year ago #

    I kept the 18, sorry. I posted on ther WPML forum also http://wpml.org/forums/topic/yoast-wordpress-seo-sitemap-xsl-error-2/ in order to see if a fix could be developped on their side... You could also post there to "push" things a little bit :)

  28. awhig
    Member
    Posted 1 year ago #

    I am having this issue as well, with .21 and WPML 3.0.1.

    I've tried the various fixes presented here:

    http://tech.graphicline.co.za/wordpress-seo-sitemap-shows-home-page/#fix2

    But nothing has worked so far.

    Thanks,
    Rich

  29. mikeotgaar
    Member
    Posted 1 year ago #

    Has anyone tried the latest version - 1.4.22? Yoast says the sitemap code was reverted to fix this issue

  30. picks44
    Member
    Posted 1 year ago #

    I've just tried it - with success. I also reverted my version of the wpseo-sitemaps-filter.php file to have the stylesheet back.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress SEO by Yoast
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic